About Store Forum Documentation Contact



Post Reply 
Esenthel 1.0 outdated?
Author Message
PsychoBoy Offline
Member

Post: #1
Esenthel 1.0 outdated?
I see that only Esenthel 2.0 SDK is updated so Esenthel 1.0 is officialy outdated?
10-27-2013 03:19 PM
Visit this user's website Find all posts by this user Quote this message in a reply
candam Offline
Legacy License Owner

Post: #2
RE: Esenthel 1.0 outdated?
I guess it's not yet it's being updated from time to time but number one priority now is version two
it's recommended for all to use it !
(This post was last modified: 10-28-2013 08:59 PM by candam.)
10-27-2013 05:22 PM
Find all posts by this user Quote this message in a reply
Pixel Perfect Offline
Legacy License Owner

Post: #3
RE: Esenthel 1.0 outdated?
I think candam meant to say 'number one priority now is version 2.0, it's recommended for all to use it!

I'd suggest that's the best course of action too unless you have already done a lot of development in 1.0 (even then it's still probably worth migrating your project to 2.0 if it's not going to cause you too much work).
10-27-2013 07:46 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Esenthel 1.0 outdated?
Hello,

I recommend upgrading to 2.0

For 1.0 licensed developer owners: I am considering making one final release of 1.0, do you want it now, or wait a few weeks for more features?
10-27-2013 10:41 PM
Find all posts by this user Quote this message in a reply
scotty1121 Offline
Legacy License Owner

Post: #5
RE: Esenthel 1.0 outdated?
(10-27-2013 10:41 PM)Esenthel Wrote:  Hello,

I recommend upgrading to 2.0

For 1.0 licensed developer owners: I am considering making one final release of 1.0, do you want it now, or wait a few weeks for more features?

Hi Esenthel, before I give you a definitive answer, are you referring to 1.0 as in the engine itself or just the editor? Because the engine and editor are both two different things to my understanding. Will 1.0 Users still get Engine updates such as HWI, Batching... etc or not?
10-27-2013 11:42 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Esenthel 1.0 outdated?
Hi, I mean the entire 1.0 SDK download package from Esenthel Store (win+mac+android+ios).
For example if I make the final release within few weeks, then the only features that you'll get will be the ones available at the time of the release.
That's why I'm asking when would you like to have the update smile
10-28-2013 12:10 AM
Find all posts by this user Quote this message in a reply
scotty1121 Offline
Legacy License Owner

Post: #7
RE: Esenthel 1.0 outdated?
with all due respect, I don't think you should retire EE1.0 Without HWI being implemented. We cannot feasably upgrade to EE 2.0 on our project and we would really need the performance increase that HWI would bring to the table. If you can at least give your word that if and when you start on HWI it will be included in 1.0 I would be most grateful, So i would have to say i'd like you to wait and put more features in, as I said HWI is really something we need.
10-28-2013 12:34 AM
Find all posts by this user Quote this message in a reply
Rubeus Offline
Legacy License Owner

Post: #8
RE: Esenthel 1.0 outdated?
It might be a good idea to at least implement the features your customers from 1.0 were relying on; to be fair, having those features on the roadmap was something of a promise to deliver.
10-28-2013 03:22 AM
Find all posts by this user Quote this message in a reply
knocks Offline
Legacy License Owner

Post: #9
RE: Esenthel 1.0 outdated?
I thought 2 was only an improved editor.
(This post was last modified: 10-28-2013 03:48 AM by knocks.)
10-28-2013 03:47 AM
Find all posts by this user Quote this message in a reply
dylantan Offline
Legacy License Owner

Post: #10
RE: Esenthel 1.0 outdated?
(10-28-2013 03:22 AM)Rubeus Wrote:  It might be a good idea to at least implement the features your customers from 1.0 were relying on; to be fair, having those features on the roadmap was something of a promise to deliver.

Yes agreed. Not mentioning that many of us still rely on 1.0
10-28-2013 08:17 AM
Visit this user's website Find all posts by this user Quote this message in a reply
miro@3dea Offline
Legacy License Owner

Post: #11
RE: Esenthel 1.0 outdated?
If this is your FINAL verdict for 1.0, I vote to wait for as many features as possible and than to release a final 1.0 update.
(This post was last modified: 10-28-2013 11:47 AM by miro@3dea.)
10-28-2013 11:43 AM
Find all posts by this user Quote this message in a reply
Dalmat Offline
Source Licensee

Post: #12
RE: Esenthel 1.0 outdated?
I am definitely for waiting for more, if we waited so long, we can hold on for some more time..
10-28-2013 11:46 AM
Find all posts by this user Quote this message in a reply
Harton Offline
Member

Post: #13
RE: Esenthel 1.0 outdated?
I give my vote to group which is waiting for more rich version of Esenthel Engine 1.0.
But I have a question related with codes for editor in version 1.0. It is possible to give us more editor codes? Now you are creating new editor 2.0 with new features and new subeditors but for us will be very very helpful when we could modify old mesh editor, data browser or waypoint tab.
In our situation, we create more hacks for unify our editors with your editor and give our designers all tools in one big editor. This is very difficult when we try add new file type to data browser or mini data browser but this is only one example. Another situation, our game is big and game designers are creating hundreds of waypoints. We create small editor where they can add colors or category for waipoint but this is big hack because we cannot touch waypoint in editor, we only override functionality or we create the same functionality once again on our side... This approach significantly increases the production.
I can pay more for full codes of editor 1.0 but is it possible case in your marketing plans?
11-07-2013 10:30 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #14
RE: Esenthel 1.0 outdated?
Hi,

Unfortunately I cannot do this, because Editor 1.0 lib uses many internal engine functions that are normally not available in the public 1.0 SDK, so you'd need to have full engine source code.
My recommendation is to upgrade to 2.0 where I'm putting more functionalities for making the Editor open for modifications via the Editor Network Interface, many users are already making use of it, for example Tottel made links between objects that are visualized with lines.
11-07-2013 10:50 PM
Find all posts by this user Quote this message in a reply
Harton Offline
Member

Post: #15
RE: Esenthel 1.0 outdated?
Thanks for fast reply!
I understand reason. But in this moment we cannot move to new version of Esenthel Engine because our team count a lot of people and we don't have enough money for licences. Maybe in the future.
11-07-2013 11:26 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply