About Store Forum Documentation Contact



Post Reply 
Linux issues
Author Message
Houge Offline
Source Licensee

Post: #16
RE: Linux issues
Hi all!

I'm trying to install EE 2.0 on Ubuntu 12.04 LTS but it requires libc6 of version 2.17 and i can install only 2.15 version (it depends on other libraries and cannot be updated). I prefer Ubuntu 12.04 to 13.10 but it seems like i will need to use 13.10. Or maybe EE Installer can be rebuilt using older version of libc6? blushing
(This post was last modified: 02-13-2014 06:14 AM by Houge.)
02-13-2014 06:13 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Houge Offline
Source Licensee

Post: #17
RE: Linux issues
Quote:~/EE$ ./Esenthel\ Installer
./Esenthel Installer: symbol lookup error: ./Esenthel Installer: undefined symbol: glXCreateContextAttribsARB

I installed everything on Ubuntu 13.10 as written in this thread, but still no success :(
I'm using Intel HD Graphics video. Any suggestions?

EDIT:
I even tried to install Bumblebee for Ubuntu (using this manual https://wiki.ubuntu.com/Bumblebee#Installation)
(This post was last modified: 02-13-2014 08:26 PM by Houge.)
02-13-2014 07:00 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #18
RE: Linux issues
Thank you for reporting this issue,
I've updated the Esenthel Linux installer archive just now, to a newer version that doesn't use 'glXCreateContextAttribsARB'.
Could you please try redownloading it?
02-13-2014 11:44 PM
Find all posts by this user Quote this message in a reply
Houge Offline
Source Licensee

Post: #19
RE: Linux issues
(02-13-2014 11:44 PM)Esenthel Wrote:  Thank you for reporting this issue,
I've updated the Esenthel Linux installer archive just now, to a newer version that doesn't use 'glXCreateContextAttribsARB'.
Could you please try redownloading it?

Thank you! But it seems like installing/reinstalling everything and resolving all unresolved dependencies i already killed my Ubuntu smile I will try it in the evening and write you back!
(This post was last modified: 02-14-2014 04:51 AM by Houge.)
02-14-2014 04:51 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Houge Offline
Source Licensee

Post: #20
RE: Linux issues
(02-13-2014 11:44 PM)Esenthel Wrote:  Could you please try redownloading it?

Error disppeared but still no luck in installing, just black screen:

[Image: image.png]
(This post was last modified: 02-15-2014 03:53 PM by Houge.)
02-15-2014 03:48 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #21
RE: Linux issues
Thanks!
I know what's wrong, I'll upload the fix in a couple of hours.
02-15-2014 07:39 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #22
RE: Linux issues
Uploading the fix right now.
02-15-2014 08:31 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #23
RE: Linux issues
The update is now available, please try again, thanks
02-15-2014 09:09 PM
Find all posts by this user Quote this message in a reply
Houge Offline
Source Licensee

Post: #24
RE: Linux issues
(02-15-2014 09:09 PM)Esenthel Wrote:  The update is now available, please try again, thanks

A new error now, window is not even opened
Code:
$ ./Esenthel\ Installer
sh: 77: Syntax error: EOF in backquote substitution
02-15-2014 10:46 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #25
RE: Linux issues
Hi,

I've just tried it but all works fine:
Using latest version of Ubuntu with all updates.


Attached File(s) Image(s)
   
02-15-2014 11:29 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #26
RE: Linux issues
Maybe it tries to start as a shell script or something?
Could you try right-clicking on the app, go to "Permissions" properties, make sure that "allow executing file as program" is enabled, then double click the app again.
02-15-2014 11:33 PM
Find all posts by this user Quote this message in a reply
Houge Offline
Source Licensee

Post: #27
RE: Linux issues
(02-15-2014 11:29 PM)Esenthel Wrote:  Hi,

I've just tried it but all works fine:
Using latest version of Ubuntu with all updates.

The same for me, Ubuntu 13.10 wih packages from documentation. Please tell me what packages did you install except the ones from documenttion?

(02-15-2014 11:33 PM)Esenthel Wrote:  Maybe it tries to start as a shell script or something?
Could you try right-clicking on the app, go to "Permissions" properties, make sure that "allow executing file as program" is enabled, then double click the app again.

Allowed.
(This post was last modified: 02-15-2014 11:34 PM by Houge.)
02-15-2014 11:33 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #28
RE: Linux issues
Do you have graphics drivers installed on your system?
I did install those from installation instructions, the graphics driver (which almost killed my linux installation), and possibly some other packages but no longer remember since there were too many.
There were a few other people here on the forums that tried the Linux version, and it did work for them.

The only issue relating to "Syntax error: EOF in backquote substitution" was in here http://www.esenthel.com/community/showth...p?tid=7385 but that was when trying to run Esenthel on a Linux without a GPU for server.

So I guess playing around with graphic drivers perhaps could solve this.
02-15-2014 11:44 PM
Find all posts by this user Quote this message in a reply
Houge Offline
Source Licensee

Post: #29
RE: Linux issues
(02-15-2014 11:44 PM)Esenthel Wrote:  Do you have graphics drivers installed on your system?
I did install those from installation instructions, the graphics driver (which almost killed my linux installation), and possibly some other packages but no longer remember since there were too many.
There were a few other people here on the forums that tried the Linux version, and it did work for them.

The only issue relating to "Syntax error: EOF in backquote substitution" was in here http://www.esenthel.com/community/showth...p?tid=7385 but that was when trying to run Esenthel on a Linux without a GPU for server.

So I guess playing around with graphic drivers perhaps could solve this.

I have Intel HD graphics video (not discrete graphics) which does rather well 3d graphics (opengl etc.) on windows. I'll try to play around and let you know tomorrow what i came to.
02-16-2014 12:21 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Houge Offline
Source Licensee

Post: #30
RE: Linux issues
No, it seems like it doesn't want to work with my intel graphics :(

I'll try to install windows and tell you if that works with the same hardware.
(This post was last modified: 02-16-2014 11:03 AM by Houge.)
02-16-2014 10:56 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply