About Store Forum Documentation Contact



Post Reply 
Mesh with blend material
Author Message
ronghester Offline
Binary Licensee

Post: #1
Mesh with blend material
I have two meshes sitting over each other on terrain. Both of these meshes uses a blending technique for showing the transparent images, on PC it works without any problem but on mobile only one mesh is visible.

[Screenshot Attached]
On mobile only the arrow is visible but the grid is not visible. On PC the meshes appears fine.

How should i fix this issue.


Attached File(s) Image(s)
   
08-04-2017 05:58 PM
Find all posts by this user Quote this message in a reply
RedcrowProd Offline
Binary Licensee

Post: #2
RE: Mesh with blend material
Heya
How do you draw this and where do you draw it ?
It might be because some function you are using are not available for mobile make sure you check the calls it should be in the comments
08-04-2017 06:08 PM
Find all posts by this user Quote this message in a reply
ronghester Offline
Binary Licensee

Post: #3
RE: Mesh with blend material
As I said they are objects placed on the terrain using editor. No code is involved.
08-04-2017 06:15 PM
Find all posts by this user Quote this message in a reply
RedcrowProd Offline
Binary Licensee

Post: #4
RE: Mesh with blend material
Sorry i did not get that from your first post wink
Have you tried switching the editor from rt deferred to actual opengl compatible render ? Like rt simple or rt forward ? Is it still draw correctly?
Even things set on the terrain in the editor needs to go thru the render phase. This might be your issue
08-04-2017 06:20 PM
Find all posts by this user Quote this message in a reply
ronghester Offline
Binary Licensee

Post: #5
RE: Mesh with blend material
Yeah something is wrong on mobile when it goes through the render phase. Thats why I am asking how to solve it.
08-04-2017 07:23 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Mesh with blend material
Your Mobile device may have lower precision for vertex/pixel shaders / depth buffer.
You may try to increase D.viewFrom, decrease D.viewRange, move the objects higher (so they have bigger distance between each other / the terrain).
08-05-2017 12:07 AM
Find all posts by this user Quote this message in a reply
ronghester Offline
Binary Licensee

Post: #7
RE: Mesh with blend material
Apparently it was a problem related to class of the object. I made the class of both the object to terrain and they are appearing fine now.

Thanks
08-05-2017 04:07 PM
Find all posts by this user Quote this message in a reply
Post Reply