About Store Forum Documentation Contact
Donations:
158$/mo



Post Reply 
Mesh Editor: Vertex paint has strange behaviour
Author Message
higgsison Offline
Member

Post: #1
Mesh Editor: Vertex paint has strange behaviour
Hi,

i have problems with vertex painting. First I use automatic skinning. I select a bone to manually chnge weights. I use RMB to gain weight and STRG+LMB to lower the weight. For now its ok. Then I select an other bone and do the same. So.. when I then select the previous bone i manipulated, the weight changed randomly more or less on the whole model.

What I am doing wrong?
02-24-2010 03:50 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Mesh Editor: Vertex paint has strange behaviour
you can use Ctrl+RMB and Ctrl+LMB,
maybe you accidentaly painted on other vertexes?
02-24-2010 07:31 PM
Find all posts by this user Quote this message in a reply
higgsison Offline
Member

Post: #3
RE: Mesh Editor: Vertex paint has strange behaviour
its always the same, when ever i try. so i decided to do it in blender and b3d export, and there comes another problem. weight paiting is ok, but importing the b3d to mesh editor results in object is turned around by 180° on the z-axis.
when i play an animation the model is cut in half and rotated by 180°.
i am playing around all day long and did not find a solution...
exporting in collada results in wrong armature...
the .x exporter doesnt export the armature...
02-24-2010 10:36 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Mesh Editor: Vertex paint has strange behaviour
I havent experienced any problems with vertex weight bone painting in ME.
could you send me a short video with the problem?
02-25-2010 12:07 AM
Find all posts by this user Quote this message in a reply
higgsison Offline
Member

Post: #5
RE: Mesh Editor: Vertex paint has strange behaviour
i got it with mesh editor

i found out that it affects only vertices not grouped with any other bone. i think it has something to do with automatic skinning, if i remove weight from an bone, an other one gets grouped with the vertices. so i did not used the weight remove (strg+lmb) anymore. first i weight painted every bone and than did the precision, without removing weight, but assigned the vertices to the right bone.

skinning ready, animations run perfectly... so i dont have to mind anymore of export/import formats for this, hehe

ps: for weight painting i used now strg+rmb instead of only rmb
(This post was last modified: 02-25-2010 05:08 PM by higgsison.)
02-25-2010 05:06 PM
Find all posts by this user Quote this message in a reply
Post Reply