About Store Forum Documentation Contact
Donations:
225$/mo



Post Reply 
3D Sound doesn't work?/ World Editor
Author Message
Harry Offline
Member

Post: #1
3D Sound doesn't work?/ World Editor
When I start "sound 3D" tutorial or my game i haven't got 3d sound effect. I'm not sure whether it is the engine problem or my computer (I changed my motherboard about two weeks ago and I have new sound drivers)
(This post was last modified: 08-08-2010 07:30 PM by Harry.)
08-07-2010 11:34 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: 3D Sound doesn't work?
I tested it recently, it's working ok
08-07-2010 11:49 PM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #3
RE: 3D Sound doesn't work?
I made some tests and I have 3d sound only when only left and right speakers are active. When I select configuration to 3.1 or 5.1 it doesn't work. Maybe someone have any ideas what can I do because I haven't?

EDIT: When I turn on WE I have another problems:

http://img641.imageshack.us/gal.php?g=87380130.jpg

I have the newest drivers for my graphic card (Radeon HD5770).
(This post was last modified: 08-08-2010 07:27 PM by Harry.)
08-08-2010 06:53 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: 3D Sound doesn't work?/ World Editor
do you have good enough PSU?
WE or WE dx10+ ?
do other 3d games work?
08-09-2010 10:03 AM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #5
RE: 3D Sound doesn't work?/ World Editor
WE in DX9 (I have Windows XP now). This issue is only in WE. Forest Valley and games like Crysis or GTA 4 works perfectly. My PSU has 500W.
08-09-2010 08:35 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: 3D Sound doesn't work?/ World Editor
is your gpu/cpu overclocked or overheating?
08-09-2010 09:14 PM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #7
RE: 3D Sound doesn't work?/ World Editor
Temperature of cpu/gpu is about 32-40 in idle and about 50 when I play games. Gpu is overclocked by default (Gigabyte Super Overclock version).
08-09-2010 11:03 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #8
RE: 3D Sound doesn't work?/ World Editor
Could you reinstall latest DirectX Runtime (not directx sdk, just runtime)

Could you try some other version of the graphics driver?

does the error occur with an empty scene too?

does any setting of Video Option + Environment Option remove the error?

for example remove all effects, and set "simple renderer" ?

is it possible you could install windows vista/7 and try also dx10+ version?
08-11-2010 09:38 AM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #9
RE: 3D Sound doesn't work?/ World Editor
(08-11-2010 09:38 AM)Esenthel Wrote:  Could you reinstall latest DirectX Runtime (not directx sdk, just runtime)

Could you try some other version of the graphics driver?

does the error occur with an empty scene too?

does any setting of Video Option + Environment Option remove the error?

for example remove all effects, and set "simple renderer" ?

is it possible you could install windows vista/7 and try also dx10+ version?

How can I reinstall DirectX Runtime? When I want to install it i have information that the newest version is already installed. I tried to use DirectX Eradicator program to delete DirectX from computer but without any effect.

Yes. This first image was from epty scene.

Now I can't get this error again because it doesn't show always, but when I tested Forest Valley in Deffered rendering when I start game state I have black screen and I don't see anything, but game is started (only GUI is working properly). This issue doesn't show always too and disappear if i move quickly mouse.
08-11-2010 10:59 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply