About Store Forum Documentation Contact
Donations:
197$/mo



Post Reply 
ME DX10+ Skeletal Inconsistencies
Author Message
llynx Offline
Member

Post: #1
ME DX10+ Skeletal Inconsistencies
ME DX10+: Load Mesh->Skel->Anim results in improper skinning of the mesh [Left screen]
ME DX9: Load Mesh->Skel->Anim results in correct skinning of the mesh [Right screen]

Same mesh/skel/anim used in both.


Attached File(s) Image(s)
   
(This post was last modified: 09-06-2010 03:49 AM by llynx.)
09-06-2010 03:48 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: ME DX10+ Skeletal Inconsistencies
Does the foot has correct skinning?
How many bones do you have in skeleton?

If skinning is correct please send me mesh+skel+anim for verification.
09-06-2010 11:29 AM
Find all posts by this user Quote this message in a reply
llynx Offline
Member

Post: #3
RE: ME DX10+ Skeletal Inconsistencies
It is skinned correctly in ME Dx9, but in ME Dx10 all bones beneath the waist are either not skinned or not properly skinned.

66 bones.

___
Basically the image on the left is the model in it's initial pose with inconsistent skinning while attempting to animate the first frame of the animation which is supposed to look like the 2nd image.
(This post was last modified: 09-06-2010 07:12 PM by llynx.)
09-06-2010 05:36 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: ME DX10+ Skeletal Inconsistencies
Thank you very much!
There was a small bug, I fixed it, it will work for next release! smile
09-07-2010 06:11 PM
Find all posts by this user Quote this message in a reply
Post Reply