About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Beginning
Author Message
Dwight Offline
Member

Post: #1
Beginning
Dear Esenthel,

My "Team" has experience in designing and creating MMO's mainly with ready out-of-the-box, plug-and-play engines (read: Realm Crafter Standard and Realm Crafter Pro).

I have a basic knowledge of C++ and I'm learning the Tutorials, and they make sense and I can play with it enough.

However, problems arise from this point onwards: I have been checking the Wiki and also have been checking how to create a new project. The basics on the Wiki are very clear, and I can manage to create a simple project with the accompanied server.

Questions boils down to this: How can I create a basic MMO game? I have downloaded the SDK (ofcource), the MMO itself and the source.

Is it "just put the data in the data, run the .pak packer and put the source in the source folder" --> Run the Editor and re-choose the folder to the MMO folder?

We are trying to do it ourselves, but it's always better to ask for some guidance of people better than us.

SnowCloud Entertainment - We are recruiting!
http://www.sc-entertainment.com
12-14-2010 10:20 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Beginning
Hi,

Once you download the Esenthel MMO Data, and extract it, there's a readme inside.

Please check it, just copy the necessary files from SDK to it, build the world (with setting correct Data path in the Editor first), extract sources to the same folder, and compile and run them.
12-14-2010 10:40 PM
Find all posts by this user Quote this message in a reply
Dwight Offline
Member

Post: #3
RE: Beginning
When I open the Esenthel MMO (Microsoft Visual Studio Solution) I see "Client" and "Server" as it should be, though when trying to build the solution, it skips both.
There is also no source, nor headers. The following screenshot will clarify the problem:
http://img137.imageshack.us/img137/5193/error1x.jpg

In the pop-up window before the conversion, it gives an error (not shown here, though the error says: "Some errors occured during conversion. For more information, see the conversion report." I ticked the checkbox that I wanted to see the report, and the above screenshot shows my next screen.)

When I try to build it, it skips. Could you explain what is going on?

SnowCloud Entertainment - We are recruiting!
http://www.sc-entertainment.com
12-15-2010 10:47 AM
Find all posts by this user Quote this message in a reply
Chris Offline
Member

Post: #4
RE: Beginning
Visual Studio 2010 express can't convert x64-bit builds (the parser breaks) - it's a silly bug by Microsoft.

You've got any of these choices:

- Use Visual C++ 2008 (express or pro) or 2010 professional - best option if you wanna release x64-bit builds.
- Use Tutorials 2010.sln - copy it to your project folder with Tutorials.vcproj - rename them and refactor them in your own project (testing by compiling along the way incase you do anything wrong). Re-add the source files.
- Edit the original Esenthel MMO.vcproj and manually remove (using something like Notepad++) everything node (and children respectively) which says "x64" - there are quite a few. It'll then convert.
- Wait for the Esenthel MMO sources to be updated with a 2010.sln as well, like the tutorials have smile

There may be a way to get 2010 express to support x64 conversions/builds but i'm not sure, I use a professional version given by our department.
12-15-2010 11:16 AM
Find all posts by this user Quote this message in a reply
Dynad Offline
Member

Post: #5
RE: Beginning
Sorry for saying this... Please use the search button, you can find this button on the top of this page. There are many threads made about this problem so if you just have used the search button you didn't need to ask here.

There is always evil somewhere, you just have to look for it properly.
12-15-2010 11:24 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Beginning
Hi, I'll upload solution+project files for VS2010 for EMMO and ERPG2 later today in the evening.
12-15-2010 12:27 PM
Find all posts by this user Quote this message in a reply
Dwight Offline
Member

Post: #7
RE: Beginning
(12-15-2010 11:24 AM)Dynad Wrote:  Sorry for saying this... Please use the search button, you can find this button on the top of this page. There are many threads made about this problem so if you just have used the search button you didn't need to ask here.

Thank you for noticing, but I did not know that Microsoft Visual Studio could not do those things with x64.

And thanks Esenthel for updating this fast!

SnowCloud Entertainment - We are recruiting!
http://www.sc-entertainment.com
12-15-2010 05:28 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #8
RE: Beginning
Hi!

I've just uploaded the projects for VS 2010 (MMO and RPG2).

It should work ok, if there are any other problems let me know.
12-15-2010 06:05 PM
Find all posts by this user Quote this message in a reply
Post Reply