About Store Forum Documentation Contact
Donations:
364$/mo



Post Reply 
Animation Problem.
Author Message
Salival Offline
Member

Post: #1
Animation Problem.
Hello, I have a problem with animations that I hope to resolve through this threadsmile. Anyway, the model and skeleton works flawlessly and looks good. But when I add the animations everything looks strange, as everything gets stretched by the animation.

Everything works well if I import it into MilkShape 3D but not in esenthel model editor.

Here is the file psk and psa file.

EDIT:

I did some small tests with MilkShape 3D. I try to import. .psk & .psa files and everything looked good and the animations work as they should, then try I export to .b3d(Blitz3D) and then import this format to the esenthel model editor then worked. Animations are not broken and all looks just fine. But all animations are in the same file not in many .anim files like if you import .psa files.

So the problem is therefore import function of .psa (animation files) files to esenthel model editor.
(This post was last modified: 02-16-2011 08:17 AM by Salival.)
02-15-2011 09:02 PM
Find all posts by this user Quote this message in a reply
llynx Offline
Member

Post: #2
RE: Animation Problem.
Quick note, the problem looks like it is with the position keyframes, from a quick test, deleting all of them for a few bones puts the bones in the correct relative positions.

e.g. (attachment)

I think this is what it should normally look like no?

I had a few issues with this when importing bvh files with unnecessary position locs and deleting them fixed the issues.

Note for esenthel, it would be useful add options for animation editing "Delete Position Keyframes"/"Delete rotation keyframes" etc etc instead of just delete all keyframes.


Attached File(s)
.rar  angry_Q.rar (Size: 241.57 KB / Downloads: 11)
(This post was last modified: 02-15-2011 10:11 PM by llynx.)
02-15-2011 10:02 PM
Find all posts by this user Quote this message in a reply
Salival Offline
Member

Post: #3
RE: Animation Problem.
Thanks for your help llynx, I agree to add the "Delete Position Keyframes" / "Delete rotation keyframes" option, or maybe do this at the actual import. Lets see what Grzegorz says. The question then is why does it works if you first export to .B3d and then put it into esenthel editor?
(This post was last modified: 02-16-2011 08:27 AM by Salival.)
02-16-2011 08:26 AM
Find all posts by this user Quote this message in a reply
llynx Offline
Member

Post: #4
RE: Animation Problem.
(02-16-2011 08:26 AM)Salival Wrote:  Thanks for your help llynx, I agree to add the "Delete Position Keyframes" / "Delete rotation keyframes" option, or maybe do this at the actual import. Lets see what Grzegorz says. The question then is why does it works if you first export to .B3d and then put it into esenthel editor?

No format is perfect and not every program exports the same way nor always the "right" way.

You have to find what works for you. But sometimes this sort of thing happens where the bone offsets are exported incorrectly and you just have to delete them (as long as they are not crucial).
02-16-2011 10:12 AM
Find all posts by this user Quote this message in a reply
Salival Offline
Member

Post: #5
RE: Animation Problem.
Grzegorz, Can you add this option (Delete all offset Keyframes)? I have many models I need to import smile

Thank you.
02-16-2011 03:59 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Animation Problem.
Im checking this.
02-16-2011 06:06 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #7
RE: Animation Problem.
Please send me the .max file, I need to check this from max, and manually export to psk/psa
02-16-2011 06:13 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #8
RE: Animation Problem.
From what I see your PSA files are broken (PSA should contain full skeleton in correct pose)
If you start milkshape, and import only your PSA (no PSK) then you'll notice that there is no good skeleton.
In the milkshape folder (default installation) there is sample PSA available, you can load it, and see that it contains a good skeleton.
02-16-2011 06:20 PM
Find all posts by this user Quote this message in a reply
Henrik Offline
Member

Post: #9
RE: Animation Problem.
I'm working along with Salival and he's currently not available. I've attached a rar with all files available to see if we're missing out on something. Are these broken as well?

File was too big for attaching actaully, uploaded to rapidshare instead.

http://rapidshare.com/files/448284319/Castanic_girl.rar
02-16-2011 06:53 PM
Find all posts by this user Quote this message in a reply
Salival Offline
Member

Post: #10
RE: Animation Problem.
(02-16-2011 06:20 PM)Esenthel Wrote:  From what I see your PSA files are broken (PSA should contain full skeleton in correct pose)
If you start milkshape, and import only your PSA (no PSK) then you'll notice that there is no good skeleton.
In the milkshape folder (default installation) there is sample PSA available, you can load it, and see that it contains a good skeleton.

PSA file is not broken, it works without problems if I delete all keyframes position offset from the loaded animation file.

I do not want to sit and remove one each time, Would love to have a button that removes all positions offset keyframes for the loaded animation.

Can you add this please grin
02-16-2011 07:21 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #11
RE: Animation Problem.
(02-16-2011 06:53 PM)Henrik Wrote:  I'm working along with Salival and he's currently not available. I've attached a rar with all files available to see if we're missing out on something. Are these broken as well?

File was too big for attaching actaully, uploaded to rapidshare instead.

http://rapidshare.com/files/448284319/Castanic_girl.rar

Hello,

I've asked for .max files so I can test exporting using ActorX plugin (official PSK/PSA file generator).
the package contains PSK+textures+GPK (which I don't know what it is)

Quote:PSA file is not broken, it works without problems if I delete all keyframes position offset from the loaded animation file.
yes it is broken, because it doesn't have the correct skeleton as I stated before.
How did you generate the PSA?
please use 3ds max + ActorX plugin.
02-16-2011 08:20 PM
Find all posts by this user Quote this message in a reply
Post Reply