About Store Forum Documentation Contact
Donations:
158$/mo



Post Reply 
Fix Autofix in Code Editor
Author Message
runewake2 Offline
Member

Post: #1
Fix Autofix in Code Editor
Has anyone else noticed that if you type Int in the Code Editor it corrects it as InterpolatorA. Can we make it so that it does not correct a function/statement etc if it exists?

It is annoying.
08-09-2011 04:24 AM
Find all posts by this user Quote this message in a reply
Driklyn Offline
Member

Post: #2
RE: Fix Autofix in Code Editor
This is because Int doesn't even show up in the autocomplete window. According to the Code Editor Wiki page, you are supposed to be using int (all lowercase) instead. "int" does appear in the autocomplete window.

Personally, I don't like when IDEs automatically change your code, so I enabled the "Autocomplete on Enter only" option (Edit > Options, or press F9). This way, pressing space will simply enter a space and not autocomplete the highlighted word. You must press enter for that to happen.
08-09-2011 07:13 AM
Find all posts by this user Quote this message in a reply
runewake2 Offline
Member

Post: #3
RE: Fix Autofix in Code Editor
Ah, thank you.
08-09-2011 09:51 PM
Find all posts by this user Quote this message in a reply
Post Reply