About Store Forum Documentation Contact
Donations:
289$/mo



Post Reply 
Problem with linking mesh to skeleton
Author Message
kulesz Offline
Member

Post: #1
Problem with linking mesh to skeleton
What do I need to do, to link mesh with a skeleton properly?
In editor I'm setting helmet in particular place (like in a screen), the mesh is automaticaly linked with skeleton (I suppose so) and then I draw it with:
Code:
HelmetItem->mesh->draw(owner.cskel);
It is drawn in a proper height, but it doesn't rotate in x axis.
Should I link it with specific bone? How to do it?


Attached File(s) Image(s)
       
(This post was last modified: 10-10-2011 06:46 PM by kulesz.)
10-10-2011 06:45 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Problem with linking mesh to skeleton
after linking with skeleton you need to set per-vertex skinning
10-10-2011 07:36 PM
Find all posts by this user Quote this message in a reply
kulesz Offline
Member

Post: #3
RE: Problem with linking mesh to skeleton
Ok, sorry for lame question, but I have no idea, where to do it - didn't have to bother about models till now ;-) How should I set per-vertex skinning?
10-10-2011 07:48 PM
Find all posts by this user Quote this message in a reply
kulesz Offline
Member

Post: #4
RE: Problem with linking mesh to skeleton
Neither can't find it in editor nor code...
10-12-2011 10:58 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #5
RE: Problem with linking mesh to skeleton
there is video tutorial in model editor main website page (tab key, or through menu skeleton option)
10-12-2011 11:00 AM
Find all posts by this user Quote this message in a reply
Post Reply