About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Latest Editor issues
Author Message
dragonfly3 Offline
Member

Post: #1
Latest Editor issues
Since I updated the new editor it seems to be a MASSIVE memory hog. I can't even test play my game world now. I have a pretty large game world and when I try to test play it the editor stops responding and freezes. When I ctrl+alt+del and check processes it shows memory usage for the editor at 444,000k, 667,000k, and even up to 774,000k. Why on earth is it chomping up memory like that? I have 3GB of RAM and an AMD 64 dual core processor. I've never had any problems like this until after I updated the editor. It seems there is a memory leak.

Also, it takes forever for it to build the new pathing. Is it supposed to?

It also takes forever (over 5 minutes) to actually load the screen after the "Done" bar is finished. And again, a memory spike is experienced with this.

The editor worked fine before I did October's update, but now I'm having all sorts of problems with it with a very large game world.
(This post was last modified: 10-25-2011 06:59 AM by dragonfly3.)
10-25-2011 06:03 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Latest Editor Memory issues
Hi,

700MB usage for a big world doesn't seem to be big.

Recast library support was added which may cause some issues.

On my computer building paths for worlds takes about 1.5x time needed for "generating terrain".

You can increase "Cell Size" in world path mode (this will decreased presicion, build time and memory usage for the path of the world)

On my computer it takes up to 3 seconds to update and play visible part of some average sized world.

it would be best if you could provide me your whole "data" folder archived, so I could test your world manually (building, loading, etc) and provide some more info.
10-25-2011 11:25 AM
Find all posts by this user Quote this message in a reply
Grabonito Offline
Member

Post: #3
RE: Latest Editor Memory issues
I have the same problem. Editor of the bloody massacre is much faster.
10-25-2011 01:13 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Latest Editor issues
please provide me data folder and video showing the issue.
10-25-2011 01:44 PM
Find all posts by this user Quote this message in a reply
dragonfly3 Offline
Member

Post: #5
RE: Latest Editor issues
My data folder is almost 4gb in size. How should I provide it?

Also, I tested again several times and never hit 774,000 again but it always spiked & climbed during pathing generation. It maxed at 581,000 through these tests. My lead programmer also tested it and experienced the same thing.

On a side note, how does the new pathing work with objects? Are there certain settings needed for MOBs & NPCs? Buildings? How does it differ from physics or lack thereof, on some objects?
10-26-2011 12:15 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Latest Editor issues
please read version history release notes, it's all there
you can visualize paths in world editor game mode using \ key
you can perform custom pathfinding using Game::World.path()...
etc

high memory usage during path generation is normal
10-26-2011 01:18 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #7
RE: Latest Editor issues
For now please make only the video. I am interested in the slowdown
10-26-2011 10:51 AM
Find all posts by this user Quote this message in a reply
Tottel Offline
Member

Post: #8
RE: Latest Editor issues
I'll just continue in this thread.

Is it possible to add a "show paths" option in the view-menu? Because I'm using an azerty-keyboard, and the backslash shortcut doesn't work here (backslash is Ctrl + alt + button next to LeftShift).
10-26-2011 01:39 PM
Find all posts by this user Quote this message in a reply
llynx Offline
Member

Post: #9
RE: Latest Editor issues
(10-26-2011 01:39 PM)Tottel Wrote:  I'll just continue in this thread.

Is it possible to add a "show paths" option in the view-menu? Because I'm using an azerty-keyboard, and the backslash shortcut doesn't work here (backslash is Ctrl + alt + button next to LeftShift).

I noticed this as well. backslash doesn't work for me and neither does Tilde '~'
(This post was last modified: 10-27-2011 12:14 AM by llynx.)
10-27-2011 12:13 AM
Find all posts by this user Quote this message in a reply
dragonfly3 Offline
Member

Post: #10
RE: Latest Editor issues
I'm not sure how to make a video other than to film the screen with an actual camera. It takes around 4-5 minutes for my world to build. Fraps won't capture the windows task manager which shows the memory increase
11-03-2011 07:22 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Tottel Offline
Member

Post: #11
RE: Latest Editor issues
Use CamStudio, it can capture your entire desktop.
11-03-2011 12:23 PM
Find all posts by this user Quote this message in a reply
Driklyn Offline
Member

Post: #12
RE: Latest Editor issues
The newest versions of Fraps can too.
11-03-2011 09:22 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #13
RE: Latest Editor issues
@dragonfly3 : How long does it take to build worlds from the SDK? (like "path.world")
by 4-5 minutes you mean whole world or only part? once I see the video I'll know more
11-05-2011 03:19 PM
Find all posts by this user Quote this message in a reply
Grabonito Offline
Member

Post: #14
RE: Latest Editor issues
Now works as it should.
11-19-2011 12:27 PM
Find all posts by this user Quote this message in a reply
Post Reply