About Store Forum Documentation Contact
Donations:
392$/mo



Post Reply 
Help in Up axis on animation
Author Message
LINOGE Offline
Member

Post: #1
Help in Up axis on animation
Hello all, I'm having some issues on importing animations and I would like to ask for some help if possible.

I have downloaded some .BIP files and loaded them on my model, in 3ds max 2011 instead of create my own animations, just to save some time. I loaded the .BIP file, fixed the key frame length and them export it to .DAE (open collada plugin), all fine but when I import the .DAE file into the esenthel editor (in model editor -> animation tab) it turn the up axis, and my animation play fine, but with wrong up axis, my model turn to the left.

I think its not a esenthel editor issue but something I'm doing wrong when importing .BIP files or when exporting it to .DAE file.

Can some one give me some light to solve this?

Thank you.
11-06-2011 07:40 PM
Find all posts by this user Quote this message in a reply
Brainache Offline
Member

Post: #2
RE: Help in Up axis on animation
When you export from 3d Max to FBX... in the export options, under "Advanced Options" there is an option for Axis conversion where you select what axis to use as your Up axis... that'll probably take care of it
11-06-2011 11:43 PM
Find all posts by this user Quote this message in a reply
LINOGE Offline
Member

Post: #3
RE: Help in Up axis on animation
Hey Brainache, thanks for reply. Well, it would take care yes, but i already did try it, i can't import animations in a FBX file to esenthel editor. When i try to import FBX, the animation dont run on esenthel editor, just nothing hapen. FBX seems not work for me to import animations into esenthel. It work for you?
11-06-2011 11:55 PM
Find all posts by this user Quote this message in a reply
LINOGE Offline
Member

Post: #4
RE: Help in Up axis on animation
Hmm, seems i got it. To have an FBX animation running on a mesh, this mesh must be imported in FBX file format too. My old mesh was imported in DAE format. I just changed it to FBX, and now the animation run fine, with Z up axis working well.

Thank you.
11-07-2011 12:58 AM
Find all posts by this user Quote this message in a reply
Post Reply