About Store Forum Documentation Contact
Donations:
327$/mo



Post Reply 
Crash then empty world.....
Author Message
EthanC Offline
Member

Post: #16
RE: Crash then empty world.....
1. Sent to you via PM
2. I've spent the entire day systematically deleting all heightmaps and all objects (We're talking hundreds of thousands if not millions of grass objects) one chunk at a time and it makes no difference. You can ALWAYS play visible, you can NEVER play all. Even when i deleted the entire world down to just the one square under the character's feet and no other objects, crash during path generation on build all or play all.

I hate pathing. We don't need it right now and I'd rather if i/we could just disable it.
Consider it fixed, however what i did to fix it shouldn't really have needed to happen.

I had removed everything in the world, objects and heightmaps and still the crash however i forgot to delete the manual paths. Once I did that and increased the size of the path cells to an unusably high size (4) it began building fine once again. The only problem is when I try to run either the client or server i'm now getting the error:

Shader Param "FontShade0" no found.

And a second error:

Error loading ShaderTech "ParticleFlat" in Shader"".

I haven't messed with particles at all, so I have no idea why that would be. Also I'm afraid this pathing problem might disable us again unexpectedly in the future without warning, but there doesn't seem to be a lot i can do to avoid it currently.

Once that error has been cleared up (if you can offer some insight as to what the hell it means) we'll be back in business.

Appreciating the assistance thus far also by the way.
(This post was last modified: 11-18-2011 06:30 AM by EthanC.)
11-18-2011 04:35 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #17
RE: Crash then empty world.....
You must recompile your programs with latest engine sdk and use latest engine.pak
http://www.esenthel.com/community/showth...p?tid=2862

The screen from disassembly+call stack could provide me some insight into crashing
11-18-2011 09:36 AM
Find all posts by this user Quote this message in a reply
EthanC Offline
Member

Post: #18
RE: Crash then empty world.....
So as an artist and not a programmer, it's not possible for me to update it correctly myself?
11-18-2011 09:46 AM
Find all posts by this user Quote this message in a reply
rndbit Offline
Member

Post: #19
RE: Crash then empty world.....
(11-18-2011 09:46 AM)EthanC Wrote:  So as an artist and not a programmer, it's not possible for me to update it correctly myself?

open your project solution, right click solution in solution explorer and choose 'rebuild solution'. its ez. better yet - send your programmer to these forums.
11-18-2011 12:20 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #20
RE: Crash then empty world.....
Hi, good news!

With the data provided by you I was able to reproduce the error.

It seems that recast navigation library which is responsible for path mesh generation had some bug. I've reported this to recast developer, and also added some workaround for this. It will be included in next SDK.

With the workaround added I was able to successfully build your world!
11-29-2011 10:56 PM
Find all posts by this user Quote this message in a reply
EthanC Offline
Member

Post: #21
RE: Crash then empty world.....
I'm glad to hear that.

However it's a regular occurance that I had to save every ten minutes because after making some small change in the world somewhere the path generation will just hang at 80% and refuse to advance ever again, so i have to keep reverting to older versions of the world to counteract this effect.

It seems like data is getting corrupted somewhere and i'm hoping your workaround relieves this. Any estimate when we might have that update?
12-03-2011 11:29 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #22
RE: Crash then empty world.....
next update will be in next few days.
data is not getting corrupt, just there is a bug in recast library path generation.
12-03-2011 11:31 AM
Find all posts by this user Quote this message in a reply
EthanC Offline
Member

Post: #23
RE: Crash then empty world.....
Ok. Well just as I made that post last night, my most recent backup save got fragged again during a routine "clean all and play visible", so now we have zero buildable world again. Hopefully the update comes around soon otherwise we're dead in the water again same as before.
12-03-2011 09:34 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #24
RE: Crash then empty world.....
Hi,

Yes the update will be soon, today or tomorrow.

The building process should not however interfere with the "Edit" folder in any way, it only reads those files, and outputs data to "Game" folder.

By saying fragged you mean the thing you've experienced before? empty world with heightmap resolution of -1? Does that refers to the edit folder as visible in World Editor during Editing ? (not playing)

If so, can you send me the "*.world/Edit/settings" file, together with some areas "*.world/Area/x, y" with x,y coordinates close the the area coordinates you've used during building? (just a few files, like 8 or something)

I am curious why you are having problems with the edit folder.

When I was able to find the bug by reproducing your issue, I still could load the world and edit it afterwards without any problem.
12-04-2011 12:40 PM
Find all posts by this user Quote this message in a reply
EthanC Offline
Member

Post: #25
RE: Crash then empty world.....
(12-04-2011 12:40 PM)Esenthel Wrote:  Hi,

Yes the update will be soon, today or tomorrow.

The building process should not however interfere with the "Edit" folder in any way, it only reads those files, and outputs data to "Game" folder.

By saying fragged you mean the thing you've experienced before? empty world with heightmap resolution of -1? Does that refers to the edit folder as visible in World Editor during Editing ? (not playing)

If so, can you send me the "*.world/Edit/settings" file, together with some areas "*.world/Area/x, y" with x,y coordinates close the the area coordinates you've used during building? (just a few files, like 8 or something)

I am curious why you are having problems with the edit folder.

When I was able to find the bug by reproducing your issue, I still could load the world and edit it afterwards without any problem.

No, excuse me what i meant when i said "fragged" was once a world starts freezing up at 80% path generation, it'll never again be able to get past that amount, so I pretty much have to load up an earlier version to get back to work on it.

I can still technically open back up and edit that wold from the temp save but seeing as i wouldn't be able to build it/play it (as i mentioned once it starts locking up during path generation) it makes more sense to go back to working on earlier versions.
12-04-2011 07:45 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #26
RE: Crash then empty world.....
You can use the Autoupdate, fix is uploaded.
I will make announcement in version history in about an hour, once other SDK's finish uploading.
12-04-2011 10:21 PM
Find all posts by this user Quote this message in a reply
Post Reply