About Store Forum Documentation Contact
Donations:
289$/mo



Post Reply 
Spawning issue [Resolved]
Author Message
JonathonA Offline
Member

Post: #1
Spawning issue [Resolved]
Okay, so got our own custom world which is growing in size substantially and I have run into a problem.

I'm using the Esenthel MMO code.

I have no problems spawning into this world, I have created a single "start" waypoint and it works fine sometimes. However, when I put that waypoint outside of a certain area (by area I don't necessarily mean Esenthels definition of an area, it could be multiple areas), when I spawn in with a new character there is no terrain, all I can see is the sky, no character, no movement, no nothing.

Now before you ask, yes the waypoint does exist (in code, and the position coordinates are correct), yes, I have rebuilt the world entirely and saved it, yes I have ran the autoupdater and rebuilt my binaries.

But despite that, no change to the problem.

I can't give specifics on where or how far away from the center of the world my "start" waypoint has to be for this problem to occur but provided it is within a certain boundary spawning is fine, if I go beyond that boundary the above issue occurs.

Been scratching my head over this one for quite a while now and I have not been successful in finding a solution, anyone got any ideas?
(This post was last modified: 11-22-2011 12:59 AM by JonathonA.)
11-20-2011 07:10 PM
Visit this user's website Find all posts by this user Quote this message in a reply
evldmn Offline
Member

Post: #2
RE: Spawning issue
Try to make a text that shows coords, when u find out where u are recheck calculations, or waypoint coords etc etc. And when you spawn with a NEW character maybe there's something wrong in the character code.
11-20-2011 11:23 PM
Find all posts by this user Quote this message in a reply
yvanvds Offline
Silver Supporter

Post: #3
RE: Spawning issue
Had the same problem last year. Solved it with the help on the forum. Look here:

http://www.esenthel.com/community/showth...p?tid=2765
11-20-2011 11:54 PM
Find all posts by this user Quote this message in a reply
JonathonA Offline
Member

Post: #4
RE: Spawning issue
So is there no way of setting the area the waypoint is in to be the active area initially on game load? It's all well and good teleporting but my character is being inserted into the world, I would rather not have to insert the character at a default location then inject them into another location, seems a bit counter-intuitive.
Okay nevermind looks like I resolved this issue, thanks for the help though yvanvds. For future reference, if anyone should suffer the same issue using Esenthel MMO code in which the world is streaming, before you insert the character in the background loader code, update the world to the camera position (assuming your camera is set up prior to character insertion) then call objCreateNear(...) and it will do the trick.
(This post was last modified: 11-21-2011 07:34 PM by JonathonA.)
11-21-2011 07:25 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply