About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Xcode incompatability
Author Message
mystara Offline
Member

Post: #1
Xcode incompatability
It looks like the latest version of Xcode (4.3.3) no longer checks /Library/Frameworks for the cg framework. Instead, it only searches /System/Library/Frameworks and ~/Library/Frameworks (https://developer.apple.com/library/mac/...works.html)

Unfortunately, /Library/Frameworks is the place that version 2.2 of the cg framework installer places the cg framework.

Any ideas if Esenthel will work with version 3.1 of the cg framework? That was updated recently, so I'd guess it installs its files to the correct place.
(This post was last modified: 07-24-2012 08:27 AM by mystara.)
07-24-2012 08:21 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Xcode incompatability
Hello,

I have not yet tried the latest CG, but if you encounter any issues let me know and I'll investigate this.

CG is only used for creating custom shaders, so you don't need to include it for other projects.
07-24-2012 02:09 PM
Find all posts by this user Quote this message in a reply
mystara Offline
Member

Post: #3
RE: Xcode incompatability
Okay, I tried Cg 3.1 (April 2012) using the older version of Xcode.
When trying to run the shader tutorials, I get the error:

'Empty Vertex Shader Code in Technique "Main"'

I then tried Cg 2.2 with the new version of Xcode (4.3.3).
It gives the error I mentioned before.
However, if I change the Base SDK from 10.7 to 10.6, it suddenly works again.
07-24-2012 07:32 PM
Find all posts by this user Quote this message in a reply
mystara Offline
Member

Post: #4
RE: Xcode incompatability
Incidentally, the project files supplied with Esenthel will not work without modification (at the moment) under Mountain Lion (10.8).

The reason is that OS 10.8 requires Xcode 4.4, and Xcode 4.4 produces the above problems.
07-29-2012 08:59 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #5
RE: Xcode incompatability
Thank you, I'll check this.
07-29-2012 04:46 PM
Find all posts by this user Quote this message in a reply
ksubox Offline
Member

Post: #6
RE: Xcode incompatability
I wonder when this problem will be solved ?

After upgrading my iMac to Mountain Lion, adding 12Mb RAM I decided to start with Esenthel.
Today I installed cg 2.2, xcode 4.4 from AppStore, downloaded Esenthel SDK, tried to build sample and ... failed :(
(This post was last modified: 08-18-2012 08:12 AM by ksubox.)
08-18-2012 07:42 AM
Find all posts by this user Quote this message in a reply
mystara Offline
Member

Post: #7
RE: Xcode incompatability
Well, it's after Esenthel's "cool thing" on his list. So I guess it'll be soon after that.

Yeah, frustrating here too. I more or less had to stop production :/
08-18-2012 09:35 PM
Find all posts by this user Quote this message in a reply
ksubox Offline
Member

Post: #8
RE: Xcode incompatability
I'm not sure yet, but now I built sample1 with xcode 4.4.1:
1. Copied /Users/sergey/Library/Frameworks/Cg.framework to folder inside Esenthel SDK (actually any folder will be OK)
2. In Target "Tutorials" in "Build Phases" tab in "Link Binary With Libraries" list click "+" and add this folder. It was added as Cg.framework and project was built.

I'm not sure how it will work for other samples... Will see.
08-19-2012 02:08 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #9
RE: Xcode incompatability
@mystara: were you able to work with the workaround suggested by ksubox?

(please note that you need to include CG framework only if you want to create custom shaders)
08-20-2012 11:06 PM
Find all posts by this user Quote this message in a reply
mystara Offline
Member

Post: #10
RE: Xcode incompatability
Unfortunately, I've broken everything as a result of messing around with the Cg framework. I need to delete everything before I can install it all again and try again.

I'll let you know once I've tried it.
08-21-2012 10:00 PM
Find all posts by this user Quote this message in a reply
mystara Offline
Member

Post: #11
RE: Xcode incompatability
I couldn't get this to work. Although that might be because something is still messed up.

However, I DID get it to work by explicitly adding the Cg framework to the project.
09-12-2012 09:28 PM
Find all posts by this user Quote this message in a reply
Post Reply