About Store Forum Documentation Contact
Donations:
206$/mo



Post Reply 
materials problem
Author Message
uffo Offline
Member

Post: #1
materials problem
Been fooling around a better half of the day, but I just don't seem to get what's wrong.
I've set materials for my tree in material editor and there they shows correctly, but
when I load my tree in world editor there's just one material on the tree. I've saved
the material data from mesh editor and loaded them for the tree in world editor.

[Image: materials.jpg]
04-19-2009 05:02 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
Re: materials problem
Hi,

1. When you load again the tree in the Mesh Editor does it look ok in it?

2. Maybe you have accidentally set the overriding material for the object in World Editor? (in the object properties window - "mtrl" you should set it only for overriding default materials)
04-19-2009 05:22 PM
Find all posts by this user Quote this message in a reply
uffo Offline
Member

Post: #3
Re: materials problem
ooh! thanks a lot!
I thought that Mtrl just sets the materials and by default there's none grin silly me.
04-19-2009 05:44 PM
Find all posts by this user Quote this message in a reply
uffo Offline
Member

Post: #4
Re: materials problem
ok, next problem with mesh editor.
as you can see with the picture, I've modeled a chair with different set of sides for each set of texture.
all goes well to the point when I change the topmost (green part) texture which then overrides all the
pink sides with its texture, or vice verse. I've tried redoing the chair and the surfaces, but the end result is always the same.
is there some part I've overlooked?

[Image: materials2.jpg]
04-19-2009 09:59 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #5
Re: materials problem
maybe you're using the same material for different MeshPart's?
or the materials generate textures of the same file name? (generated texture file name is taken from the "color map" name)

You can check the FAQ section in the Mesh Editor documentation (on the most bottom of the doc).

If that won't help, then let me know!
04-19-2009 11:23 PM
Find all posts by this user Quote this message in a reply
uffo Offline
Member

Post: #6
Re: materials problem
gave up and build the model and surfaces all over again and now it works. not sure what I did wrong with the first attempts. mysterious!
04-21-2009 09:23 AM
Find all posts by this user Quote this message in a reply
Post Reply