About Store Forum Documentation Contact
Donations:
225$/mo



Post Reply 
Application has stopped working
Author Message
AndrewBGS Offline
Member

Post: #1
Application has stopped working
Any idea what might cause this issue?

The code compiles, the application DOES start, the intro and menu are fine, but when i want to start the game I get the <application> has stopped working error.
No "element x can not be found", "something out of range" and stuff like that, just the windows annoying has stopped working error.

Any idea what may cause this? I re-winded back my code to a version that i'm pretty sure used to work.
06-11-2013 10:26 PM
Find all posts by this user Quote this message in a reply
TBJokers Offline
Member

Post: #2
RE: Application has stopped working
Make sure you are not trying to access something that doesn't exist, something typical in this case is Memc, Memb, Memx's. Make sure that when you access those keep it inside a REPA loop or do an if statement, "if(i < MyMemc.elms())MyMemc[i].function();"
(This post was last modified: 06-12-2013 12:53 AM by TBJokers.)
06-12-2013 12:53 AM
Visit this user's website Find all posts by this user Quote this message in a reply
AndrewBGS Offline
Member

Post: #3
RE: Application has stopped working
Ok, so I figured it out. It's the same error I have every month, then I find a solution and after a while I get it again:

The layer is too far from map 0,0,0 origin. I had the camera set its position on the player position upon initialization, and that used to work until yesterday. Now once again my player has to be close to the origin to work.

How have other people coped with this problem? My solution doesn't seem to be the best.
(This post was last modified: 06-12-2013 09:37 AM by AndrewBGS.)
06-12-2013 09:04 AM
Find all posts by this user Quote this message in a reply
Post Reply