About Store Forum Documentation Contact
Donations:
395$/mo



Post Reply 
Esenthel 1.0 outdated?
Author Message
Esenthel Offline
Administrator

Post: #61
RE: Esenthel 1.0 outdated?
Mac 1.0 SDK has "EsenthelEngine.a"

"EsenthelEngine-x86.a" this is not Mac, but Android based on x86 CPU's, there are some devices with this kind of CPU
12-05-2013 12:14 AM
Find all posts by this user Quote this message in a reply
cmontiel Offline
Member

Post: #62
RE: Esenthel 1.0 outdated?
Ok thanks.
12-05-2013 12:22 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #63
RE: Esenthel 1.0 outdated?
I've finished uploading 1.0 fixes for Win/Mac/Android.
12-05-2013 01:09 AM
Find all posts by this user Quote this message in a reply
candam Offline
Member

Post: #64
RE: Esenthel 1.0 outdated?
(12-05-2013 01:09 AM)Esenthel Wrote:  I've finished uploading 1.0 fixes for Win/Mac/Android.

smile Good job that's the final update of beloved esenthel one
a way to go esenthel 2smile
12-05-2013 01:17 AM
Find all posts by this user Quote this message in a reply
laugan Offline
Member

Post: #65
RE: Esenthel 1.0 outdated?
(12-04-2013 11:59 PM)Esenthel Wrote:  
(12-04-2013 11:17 AM)laugan Wrote:  EDIT3: Ok i succeeded in compiling and running application. Had to change a lot of things (which worked earlier without change). But the problem with classes and their variables is still here.
Please attach the sample project with headers+lib, and if I find the time I can check this.

Here is the link: http://rghost.ru/50695916
You need to include "my.h | otlv4.h" headers and only one lib - "oci.lib". All headers and libs (excemt my.h) need to be in VS folders ("include" and "lib"). Example class is "otl_connect".

Thanks in advance!
(This post was last modified: 12-05-2013 06:37 AM by laugan.)
12-05-2013 06:37 AM
Find all posts by this user Quote this message in a reply
Dalmat Offline
Member

Post: #66
RE: Esenthel 1.0 outdated?
Thanks for the update!
Hope you do it again sometime smile)
12-07-2013 03:30 PM
Find all posts by this user Quote this message in a reply
Kiekos Offline
Member

Post: #67
RE: Esenthel 1.0 outdated?
Yep, thanks for the 1.0 update!

However, my project won't compile now (and even the tutorials)... I'm getting 4 "LNK 2019 unresolved external symbol" errors in both cases.
12-08-2013 01:14 AM
Find all posts by this user Quote this message in a reply
aceio76 Offline
Silver Supporter

Post: #68
RE: Esenthel 1.0 outdated?
I think you will need to be more specific, put in which symbols it is complaining about.
12-08-2013 02:04 AM
Visit this user's website Find all posts by this user Quote this message in a reply
cmontiel Offline
Member

Post: #69
RE: Esenthel 1.0 outdated?
Use autoupdate tool to get the last version.
12-08-2013 04:25 AM
Find all posts by this user Quote this message in a reply
Kiekos Offline
Member

Post: #70
RE: Esenthel 1.0 outdated?
I did use the autoupdate tool...

All of these errors point at the same function:
Code:
Error    2

error LNK2019: unresolved external symbol __imp__SetupDiDestroyDeviceInfoList@4 referenced in function "public: virtual bool __thiscall OVR::Win32::HIDDeviceManager::Enumerate(class OVR::HIDEnumerateVisitor *)" (?Enumerate@HIDDeviceManager@Win32@OVR@@UAE_NPAVHIDEnumerateVisitor@3@@Z)

C:\EsenthelEngineSDK\Tutorials\EsenthelEngine.lib(OVR_Win32_HIDDevice.obj)

Tutorials
12-08-2013 12:23 PM
Find all posts by this user Quote this message in a reply
Pixel Perfect Offline
Member

Post: #71
RE: Esenthel 1.0 outdated?
looks very like this
12-08-2013 02:27 PM
Find all posts by this user Quote this message in a reply
Kiekos Offline
Member

Post: #72
RE: Esenthel 1.0 outdated?
Yea that's it - linking 'setupapi.lib' did the trick!

Now the code compiles but the game won't run as I'm getting this error:
Shader Param ""
from Shader File "Main"
Already exists in Shader Constants Map but with different parameters.


And the only thing I did was updating the engine...
12-08-2013 10:08 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #73
RE: Esenthel 1.0 outdated?
Please use latest engine.pak, or just upgrade to 2.0
12-08-2013 10:14 PM
Find all posts by this user Quote this message in a reply
Kiekos Offline
Member

Post: #74
RE: Esenthel 1.0 outdated?
I don't have funds to update to 2.0 yet... however, I'm planning to do it.

I copied the latest engine.pak and the game runs but seconds after it finishes loading, it crashes with "element out of range" error. How can I track down the problem?
12-08-2013 10:32 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #75
RE: Esenthel 1.0 outdated?
Please use debugging, VS will point you to the error location.
12-08-2013 11:33 PM
Find all posts by this user Quote this message in a reply
Post Reply