About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Physics bug?
Author Message
krokodilcapa Offline
Member

Post: #1
Physics bug?
Hi Greg!

My problem is: I have my object created to a container (to a characters inventory), and when I place it to the world at the first time, it seems the object's actor has an impulse or force. I made a video, I hope it show it enought. smile





Important:
Originally I didn't added any force or impulse to the actor, and the sword or the shield just impacted to the ground with big force, and fly away... I fixed this - before place the sword to the world, then applied an actor.sleep() - it worked... now in the video I added an impulse to the sword after the "sleep" (I wanted to simulate I really hit out it from the hand), and I got the problem returned, but only for the first time... when the skeleton drop the sword again, there is no problem.
11-26-2014 09:34 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Physics bug?
Hello,
You could try instead of calling sleep before dropping the item , clear the actor velocities. Both vel and angVel.
11-27-2014 12:11 AM
Find all posts by this user Quote this message in a reply
krokodilcapa Offline
Member

Post: #3
RE: Physics bug?
Thanks, it works. But why do have any velocity of an actor, what I created straight in the character's create function?
11-27-2014 12:36 AM
Find all posts by this user Quote this message in a reply
Post Reply