About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Problem with linux installer?
Author Message
jnymarkp Offline
Member

Post: #1
Problem with linux installer?
Hi all

I have just purchased the smallest license to try this great piece of software.
Have a fresh installed Ubuntu 12.04 and downloaded the linux installer.zip file.
But after unpacking, the file within has no file type...?

The windoze installer is of course .exe, but i would expect the linux installer to be .deb or .rpm..?

It's a 21.8MB file created on december 14 2014.

Is it just me or is something missing?

Best Regards
Jesper
12-22-2014 10:59 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Problem with linux installer?
Hello!

Thank you for your purchase!
To my knowledge this is the file format of Linux executables - no extension.
Please try double clicking it.

Lately I only have access to Ubuntu 14.10 on which the Linux Engine version was compiled.
You may have to install Ubuntu 14.10, if the installer will fail to load on your 12.04.

Thanks! smile
12-23-2014 02:29 AM
Find all posts by this user Quote this message in a reply
jnymarkp Offline
Member

Post: #3
RE: Problem with linux installer?
Hello!

I have tried double clicking it,- with the result that Ubuntu asks me what program to use.
But i will trow in ubuntu 14.10 tonight and have a go smile
Thanks for your quick reply grin

Best Regards
Jesper
12-23-2014 06:34 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Problem with linux installer?
You could also try selecting properties on the file, and marking "executable" permission as enabled smile
12-24-2014 01:32 AM
Find all posts by this user Quote this message in a reply
Houge Online
Silver Supporter

Post: #5
RE: Problem with linux installer?
If it is built with Ubuntu 14.10 (please Greg correct me if i'm wrong) it won't work with Ubuntu 12.04. It won't even work with Ubuntu 14.04 smile
12-24-2014 07:16 AM
Visit this user's website Find all posts by this user Quote this message in a reply
jnymarkp Offline
Member

Post: #6
RE: Problem with linux installer?
Hi all smile

I have now installed Ubuntu 14.10 but it still wont install.

Code:
jesper@Ubuntu-dev:~/Downloads$ ls -la
total 21328
drwxr-xr-x  2 jesper jesper     4096 Dec 25 15:51 .
drwxr-xr-x 16 jesper jesper     4096 Dec 25 15:45 ..
-rwxrwxrwx  1 jesper jesper 21830673 Dec 15 09:15 Esenthel Installer
jesper@Ubuntu-dev:~/Downloads$ ./Esenthel\ Installer
bash: ./Esenthel Installer: cannot execute binary file: Exec format error
jesper@Ubuntu-dev:~/Downloads$

Also im strugling with installing the "lib32stdc++6" library mentioned on Esenthel's installation documentation page.
Any advice is highly appriciated smile

Thx
Jesper

Sorry guys - think i found the root cause to my problems..

For some funny reason i had downloaded and installed the 32bit version of ubuntu 14.10.
So it seems quite fair that the 64bit installer wont run ;o)

Will reinstall with 64bit Utopic Unicorn smile

I will return...

Edit: Yes that was it - running 14.10 now and Esenthel is installed smile
Sorry for the disturbance but greatly appreciate your effort!

Regards Jesper
(This post was last modified: 12-25-2014 09:10 PM by jnymarkp.)
12-25-2014 04:15 PM
Find all posts by this user Quote this message in a reply
jnymarkp Offline
Member

Post: #7
RE: Problem with linux installer?
Hmm...

It still seems that something has gone wrong.
After starting EsenthelI tried to run the first application in tutorials "1 - Basic App" wich didn't work.

Somewhere in the middle it said (Complete output attached):

Code:
g++ -m64 -fshort-wchar -fpermissive -ffast-math -ffriend-injection -Wno-int-to-pointer-cast -Wno-invalid-offsetof    -o 1\ -\ Basic\ App build/Debug/GNU-Linux-x86/Auto.o build/Debug/GNU-Linux-x86/Main.o build/Debug/GNU-Linux-x86/Commands.o /home/jnp/esenthel/Bin/EsenthelEngine.a  -Wl,-rpath,Bin -lpthread -ldl -lX11 -lXi -lXinerama -lXmu -lGL -lopenal -lz -lodbc -ludev -lXcursor -lXxf86vm -lCg -lCgGL
/usr/bin/ld: cannot find -lXi
/usr/bin/ld: cannot find -lXinerama
/usr/bin/ld: cannot find -lXmu
/usr/bin/ld: cannot find -lopenal
/usr/bin/ld: cannot find -lz
/usr/bin/ld: cannot find -lodbc
/usr/bin/ld: cannot find -ludev
/usr/bin/ld: cannot find -lXcursor

Did I miss anything during installation?

Any help greatly appreciated!

Regards amd a merry christmass to you all smile
Jesper[/php]


Attached File(s)
.txt  Output.txt (Size: 2.19 KB / Downloads: 0)
12-25-2014 09:52 PM
Find all posts by this user Quote this message in a reply
Houge Online
Silver Supporter

Post: #8
RE: Problem with linux installer?
Code:
Did I miss anything during installation?

Yes, it seems like you missed this:
http://www.esenthel.com/?id=doc#Installation

There is an apt-get part.
12-26-2014 07:10 AM
Visit this user's website Find all posts by this user Quote this message in a reply
jnymarkp Offline
Member

Post: #9
RE: Problem with linux installer?
Hi!

Actually I did that - several times.
But this last time I split the line and installed one library at a time...
And now it works...

Thanks for your help and patience smile
12-26-2014 09:40 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #10
RE: Problem with linux installer?
Glad that you've got it working now smile
12-27-2014 12:40 AM
Find all posts by this user Quote this message in a reply
Post Reply