About Store Forum Documentation Contact



Post Reply 
after september update, resource loading fail
Author Message
ralphthebear Offline
Member

Post: #1
after september update, resource loading fail
Hi,

I've been using Mar. version until now, but i update the engine with Sep. version yesterday because of GLES 3.0 support.

After that, on android, any try to loading resource makes shut down app with similar log below

Code:
09-21 17:29:05.205: I/Timeline(1210): Timeline: Activity_windows_visible id: ActivityRecord{163531ac u0 com.android.devtest/.EsenthelActivity t31304} time:120543309
09-21 17:29:05.275: D/[LGE_DATA][LGDCT](4685): topActivity.getClassName(); = com.android.devtest.EsenthelActivity
09-21 17:29:08.845: I/WindowState(1210): WIN DEATH: Window{286f86b0 u0 com.android.devtest/com.android.devtest.EsenthelActivity}
09-21 17:29:08.855: D/InputDispatcher(1210): Focus left window: Window{286f86b0 u0 com.android.devtest/com.android.devtest.EsenthelActivity}
09-21 17:29:08.855: D/InputDispatcher(1210): Window went away: Window{286f86b0 u0 com.android.devtest/com.android.devtest.EsenthelActivity}
09-21 17:29:08.895: W/ActivityManager(1210): Force removing ActivityRecord{163531ac u0 com.android.devtest/.EsenthelActivity t31304}: app died, no saved state

From figuring out by log, all code something like
'loginGui.load("zoa!c3r_tn_6qxc_ulixiax2");' makes app died.

On pc with sep. version, no problem.
On android with mar. version, no problem

Is there any clue I have to try?
09-21-2017 10:26 AM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #2
RE: after september update, resource loading fail
Thank you for reporting the problem, I've fixed it (fix available on GitHub).
I'm now recompiling the engine and will upload fixed Binary version ASAP.
09-21-2017 10:39 PM
Find all posts by this user Quote this message in a reply
ralphthebear Offline
Member

Post: #3
RE: after september update, resource loading fail
Thanks for the update.

Resource loading was fixed on android, but another problem arises.

World loading on Android has problem with Sep. version. I used to load like "Game::World.New("NewWorld/Race001.world/Game");" before. That world was made by legacy EE (maybe Esenthel 2 proto version) but until Mar. version, there was no problem on PC, Android both. After update, World wouldn't be rendered on Android system. It can render only player and dynamic object mashes. Terrain from world file wasn't rendered correctly (actually nothing appears).

With same world file,
on pc, no problem
on anroid, no problem with Mar. version

It may be ok to use Mar. version, but Mar. version has serious frame drop (10-13 fps, usually 30~40 fps on similar level mobile like LG G4) on Samsung Galaxy series with Android OS 6.x (eg. Note 4), others says that would be related QHD display but anyway with Sep. version, frame drop solved.

So I have to decide which engine to use but whatever I choose, there is a problem to solve to publish.

Welcome any advice
09-25-2017 04:17 PM
Find all posts by this user Quote this message in a reply
RedcrowProd Offline
Bronze Supporter

Post: #4
RE: after september update, resource loading fail
Hey there.
I would def. Keep up with the engine version as tons of new update and perf improvements is really nice to have.
Maybe try to see with greg if a converter or something can be done about it. Maybe tho you will need to consider doing a new map.
I like to have heightmaps for that reason it tends to be easier if something get messed up to redo it.
Populate the map nicely tends to be time consuming tho so i hope you find a way to fix your issue
09-25-2017 05:35 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #5
RE: after september update, resource loading fail
Hi,

So to clarify,
The world on latest Engine version (September):
-on Windows works OK
-on Android objects work OK, but the terrain heightmap doesn't work OK?

Does the problem occur on both LG G4 and Galaxy Note 4? Or only LG G4?
09-25-2017 11:45 PM
Find all posts by this user Quote this message in a reply
ralphthebear Offline
Member

Post: #6
RE: after september update, resource loading fail
The world on the Engine (Mar.) with Legacy World (made by EE 2)
on Windows, OK
on Android 6.01 (Note 4, S6), severe frame drop (at most 10~12) but rendering correctly
on Android 4.3, 5.1 (G2, G4, Note 3), OK (fps usually 30~60)

The world on the latest Engine (Sep.) with Legacy World (made by EE 2)
on Windows, OK
on Android 6.01 (Note 4), only character / dynamic objects rendered but soon all screen messed up but no frame drop
on Android 5.1 (LG G4, Note 3), nothing rendered even gui, if i disable 3D objects (include world), GUI rendered correctly

The world on the latest Engine (Sep.) with New World (made by EE 3)
on Windows, OK
on Android 6.01 (Note 4), OK, no frame drop
on Android 5.1 (LG G4, Note 3), with Sky.frac(1) correct rendering artifact but soon (after 20~30 secs) app died while game is progressing

At present, better option to me is to use EE (Mar. version) if I can figure out "why severe frame drop happens on Android 6.x?" Of cause, best option is to use GLES 3.0 supported EE but it would take more little time to be stable.

Looking forward for your support
09-26-2017 11:10 AM
Find all posts by this user Quote this message in a reply
ralphthebear Offline
Member

Post: #7
RE: after september update, resource loading fail
More test report (on various Android 4.3, 5.1, 6.01 or so)

If I use bigger world (one mesh map, looks like derby race track, lots of textures) than the previous test, whatever OS, mobile, all 3d rendering messed up (of course, this same map works well on Mar. version)

. all white screen from first time and soon various color, jagged screen
. at first, renders few objects (world not show only sky show up) but soon few meshes disappears from objects and messed up all, black, distorted, jagged screen or so

If you need, I would link the test screen or cam
09-26-2017 04:30 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #8
RE: after september update, resource loading fail
Hello and thank you for more information.
I will try to do some more tests using big worlds, because the tests I've done so far, work OK.
It would be helpful if you could send me an *.EsenthelProject in which I could reproduce the issues you're having.
I have a Galaxy Note 4 (with Mali GPU), and I could do tests on other popular Samsung devices.
09-26-2017 10:40 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #9
RE: after september update, resource loading fail
I was able to reproduce some issues in my game Dungeon Hero, on Note 4. I'm investigating now.
09-28-2017 07:06 AM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #10
RE: after september update, resource loading fail
The issues I'm experiencing are related to loading GPU data on secondary threads.
You could try disabling background loading:
Code:
void InitPre()
{
   Game::WorldManager::use_background_loading=false;
Please let me know if this solves the problem.
I'll work on a fix for that ASAP.
09-28-2017 08:13 AM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #11
RE: after september update, resource loading fail
Thank you very much for the bug reports, I was able to fix displaying meshes that were loaded on a secondary thread.
Tested and works fine on Android Note 4 and iOS iPad mini 2.
09-29-2017 06:12 AM
Find all posts by this user Quote this message in a reply
Post Reply