katoun
Member
|
Update function is names Main
Hello Esenthel,
Why is the update function named Main()
Quote:// DECLARATIONS FOR USER PROVIDED MAIN FUNCTIONS
/******************************************************************************/
void InitPre(); // init before engine, in this method you should modify only: applications settings (App), Display options (D), Renderer type (Renderer.type), default full viewport parameters (ViewportFull), camera parameters (Cam), path settings (IOPath), loading data paks (PakAdd), any other methods should be called later, in Init() or your custom functions
Bool Init (); // init after engine
void Shut (); // shut at exit
Bool Main (); // update
void Draw (); // draw
It puts me in dificulty because I am used for the name Main in C++ to be for a different use..
|
|
11-06-2009 05:46 PM |
|
Esenthel
Administrator
|
RE: Update function is names Main
thanks, I was thinking lately to change it to Update but forgot
|
|
11-06-2009 06:23 PM |
|