About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
linking errors
Author Message
roarcast Offline
Member

Post: #1
linking errors
Hello There,

maybe someone can help... sorry still noob in graphics and c++.. :(

i have the ffg setup..

- windows xp pro
- directx 9.0c (runtime only.. but do i really need a directx sdk?)
- mobile intel 965 with latest drivers.... (which according to what i researched and found out that ther'll be no problem realting to shader up 3.0)
- i can run the mesh viewer tool (esenthel)
- already verified headers and lib paths


but...

i am getting linking errors on tutorials which do not have the "APP_NO_FX"

1>05 - Bumpmapping.obj : error LNK2019: unresolved external symbol "public: struct EE::RendererClass & __thiscall EE::RendererClass::operator()(void (__cdecl&)(void))" (??RRendererClass@EE@@QAEAAU01@A6AXXZ@Z) referenced in function "void __cdecl Draw(void)" (?Draw@@YAXXZ)
1>Tutorials.exe : fatal error LNK1120: 1 unresolved externals


TIA
09-15-2009 09:55 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
Re: linking errors
Hi,

after you have downloaded the latest engine version, please launch again the Autoupdate tool , with Visual Studio path specified in it, it should automatically copy the headers and lib, and then please Rebuild your C++ project. (rebuild option)
09-15-2009 10:17 PM
Find all posts by this user Quote this message in a reply
roarcast Offline
Member

Post: #3
Re: linking errors
thanks for the info... btw what could be the cause in general of having that kind of linking prob?

thanks again....

also the engine rocks!!!!!!!! :E
09-16-2009 01:23 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
Re: linking errors
thanks!

the problem occurs when you use engine headers (.h) of different version than engine library (.lib)
09-16-2009 01:59 PM
Find all posts by this user Quote this message in a reply
Post Reply