About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
DEBUG Macro Access Violation
Author Message
fatcoder Offline
Member

Post: #1
DEBUG Macro Access Violation
Quote:-defining macro "DEBUG" before including esenthel engine headers will make the engine more safe for debugging purpose

I have just updated and noticed that the new DEBUG macro causes Debug builds to fail. None of the tutorials will run for me in Debug mode unless I remove the DEBUG macro. Release mode works fine.

It compiles fine, but when I run it, it breaks just after:
Code:
Paks.add("../data/engine.pak");

It comes up with an unhandled exception, access violation.

Anyone else with the problem?
03-14-2010 07:54 AM
Find all posts by this user Quote this message in a reply
mih Offline
Member

Post: #2
RE: DEBUG Macro Access Violation
I just updated the engine and I have the same problem, when trying to run any tutorial in debug mode i have such error after compilation :
[Image: errorda.th.jpg]
in release mode It works ok. Also my projects runs ok with just updated engine.pak file.
03-14-2010 03:11 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #3
RE: DEBUG Macro Access Violation
thank you for reporting this, I'll upload fixed version in 3 minutes.
appearently this certain functionality does not work on all computers.
03-14-2010 03:44 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: DEBUG Macro Access Violation
it should work ok now (when updated using Autoupdate), 7z archive is still uploading
03-14-2010 03:49 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #5
RE: DEBUG Macro Access Violation
please let me know if its ok now

PS. did everyone had this problem?
03-14-2010 04:15 PM
Find all posts by this user Quote this message in a reply
Dynad Offline
Member

Post: #6
RE: DEBUG Macro Access Violation
yea i had the same problem as well

There is always evil somewhere, you just have to look for it properly.
03-14-2010 06:28 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #7
RE: DEBUG Macro Access Violation
I built some tutorials but I hadn't any problems with them.
03-14-2010 06:36 PM
Visit this user's website Find all posts by this user Quote this message in a reply
fatcoder Offline
Member

Post: #8
RE: DEBUG Macro Access Violation
Problem fixed. Thanks.
03-15-2010 12:09 AM
Find all posts by this user Quote this message in a reply
mih Offline
Member

Post: #9
RE: DEBUG Macro Access Violation
yes, it's working now smile thanks
03-15-2010 05:18 PM
Find all posts by this user Quote this message in a reply
Post Reply