About Store Forum Documentation Contact
Donations:
140$/mo



Post Reply 
Renderer is running slow.
Author Message
Dynad Offline
Member

Post: #1
Renderer is running slow.
Hey,

Since i updated to the last version of Esenthel, i get very low fps in my game. Before update i get ~60 fps with a level around the 100k poly's. Now i don't get any further then 12fps.

Whats going on, i don't really know what the problem is.

I used the dx9 and dx10 builds (release,debug).

ps: i use a intel e8400 dual core, 6gig mem, ssd harddrive and a ati 4850.


Thnx,
~Dynad

There is always evil somewhere, you just have to look for it properly.
(This post was last modified: 04-08-2010 07:23 PM by Dynad.)
04-08-2010 07:13 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Chris Offline
Member

Post: #2
RE: Renderer is running slow.
I sent a copy of my game to my graphics artist and he's getting the same issues, Q6700 @2.6ghz, 4 CPU's. Nvidia GeForce 210 1024mb - about 2-12fps on sample.world (+water) - he says its not 2fps though, more like 8-20.
04-08-2010 07:20 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #3
RE: Renderer is running slow.
Thanks, I'll check this out
04-09-2010 12:53 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Renderer is running slow.
could you try installing latest graphics drivers?

I've checked performance of ERPG2 built with latest engine version, and it looks the same.

Are you using latest engine.pak? headers, lib files?
04-09-2010 01:01 AM
Find all posts by this user Quote this message in a reply
Chris Offline
Member

Post: #5
RE: Renderer is running slow.
Dan, my graphics artist, and I are both running the same packed single .exe (no dependencies, latest version, latest engine.pak). I've asked him to upgrade his graphics driver, will let you know if it changes anything. He's running Windows XP SP3 32bit. It works seemingly normally for me on an i5 750 Win 7 x64

His response after updating:

Quote:[02:12:21] Dan: 13ffps = all stats
[02:12:41] Dan: 58-60 simple renderer
[02:12:58] Chris Willcocks: and simple renderer with the VSync disabled?
[02:13:22] Dan: off it's 76-85
[02:13:27] Dan: er.. 87
[02:13:40] Chris Willcocks: hmmm... it sounds more normal now, is it?
[02:13:50] Dan: except
[02:13:59] Dan: im getting some random slowdown without vsync
[02:14:16] Chris Willcocks: vsync ON should make things look smoother
[02:14:21] Chris Willcocks: that's the point of it..
[02:14:25] Dan: every other second things go into slowmo
[02:14:38] Chris Willcocks: on or off?
[02:14:55] Dan: when off
[02:15:04] Dan: all setings and AO off I get 12-15 fps
[02:15:54] Dan: also getting random speed increases/decreases. but dont think of them as a frame hit, thing of them as slow or fast motion
shadowmap size causes no real difference, either in count or preformance
[02:17:22] Dan: neither does shadow softening
[02:18:09] Dan: turning off bump mapping [from relief] gets me about an extra 5fps on the number. but no real noticeable change
motion blur makes no difference what-so-ever
[02:18:51] Dan: keep in mind, im running in window mode chris
[02:19:39] Dan: AO on ultra or high makes no real change either in FPS or otherwise
[02:19:58] Chris Willcocks: window mode shouldn't make that much difference
[02:20:06] Dan: but flip it off and it says I go from 12fps to 16fps in daytime, to 30fps in nighttime
[02:20:41] Dan: turning off hdr puts me up to 15fps
[02:21:02] Dan: high precision RT's makes no noticeable difference
[02:21:09] Dan: this is with sync on
switching to forward renderer puts me at 60fps at night, 30fps in day
[02:22:21] Dan: simple is about 60 in day and night
[02:23:03] Dan: with sync off, FR is 111-120 day, 125 at night
(This post was last modified: 04-09-2010 02:22 AM by Chris.)
04-09-2010 01:56 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Renderer is running slow.
Background processes can make changing in performance.

What was Dan's performance with the same setttings before update, and what's the performance after update?

Are you sure performance drop is caused because of engine update, and not because you've changed something in your project?
04-11-2010 06:07 AM
Find all posts by this user Quote this message in a reply
Post Reply