About Store Forum Documentation Contact
Donations:
207$/mo



Post Reply 
My Game base app: failed build with link error [solved]
Author Message
Antony Offline
Member

Post: #1
My Game base app: failed build with link error [solved]
Followed 'Creating base application' at end of Barthap's Beginners Tutorial, but getting build fail. Redid a second time after carefully following Visual Studio Settings for project.

Still get build fail with following debug info: "Linking...
LINK : warning LNK4031: no subsystem specified; CONSOLE assumed
libcmt.lib(crt0.obj) : error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup
customersYacht.exe : fatal error LNK1120: 1 unresolved externals
(This post was last modified: 12-14-2010 11:23 PM by Antony.)
12-07-2010 11:31 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: My Game base app: failed build with link error
Hi,

why aren't you using supplied visual studio projects from the SDK?
They're available for both 2008 and 2010.
12-08-2010 01:04 AM
Find all posts by this user Quote this message in a reply
Antony Offline
Member

Post: #3
RE: My Game base app: failed build with link error
Problem solved. My first fresh app (using just the 00 - Start.cpp) works.

Before, I was trying to do it the harder way (make a New Project, manually adjust debug and release configuration properties etc.) to help me learn VC and your engine. I bit off more than I could chew.

Thanks for taking time to respond and help me.
12-08-2010 05:29 AM
Find all posts by this user Quote this message in a reply
Post Reply