About Store Forum Documentation Contact
Donations:
243$/mo



Post Reply 
starting?
Author Message
ArmyOfTwo Offline
Member

Post: #1
starting?
Are there any tutorials how to start?
Because i am kinda new to visual basic, and i did http://www.esenthel.com/wiki/index.php?t...on_Windows

and then i don't know what to do next?
12-10-2010 05:12 PM
Find all posts by this user Quote this message in a reply
Tottel Offline
Member

Post: #2
RE: starting?
EsenthelEngineSDK/Tutorials/ Inside this folder, you find tutorials.sln, launch that.

Now you can continue browsing into the 'source' folder In here, you find tons of 'tutorials' (single documented code files). Simply replace start.cpp (in tutorials.sln) with the tutorial file that you want to try and hit f5 to build.
12-10-2010 05:23 PM
Find all posts by this user Quote this message in a reply
ArmyOfTwo Offline
Member

Post: #3
RE: starting?
When i try to build a tutorial it shows

Unable to start program
EsenthelSDK\Tutorials\Template\Tutorials.exe
12-10-2010 06:22 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: starting?
EsenthelSDK\Tutorials\Template\Tutorials.exe

where did "Template" come from? there shouldnt be any template

Are you using provided Tutorials.sln file?

which Visual Studio are you using?
You mentioned something about Visual Basic, EE runs on Visual C++
12-10-2010 06:33 PM
Find all posts by this user Quote this message in a reply
ArmyOfTwo Offline
Member

Post: #5
RE: starting?
I meant visual C++, i know C++ basics as i were coding an language what comes from C++, its called pawn.
Its first time i am working with visual C++
This is how it looks like
http://img715.imageshack.us/img715/8805/...ii88bx.jpg
12-10-2010 06:45 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: starting?
Didn't you delete some folders from the VS project?

Because you're missing H and Source folders from the screen.


Attached File(s) Image(s)
   
12-10-2010 07:12 PM
Find all posts by this user Quote this message in a reply
Driklyn Offline
Member

Post: #7
RE: starting?
(12-10-2010 06:22 PM)ArmyOfTwo Wrote:  When i try to build a tutorial it shows

Unable to start program
EsenthelSDK\Tutorials\Template\Tutorials.exe

Try looking for Tutorials.exe inside the Tutorials folder itself. I get the same error when building tutorials.

To fix this, go to Project > Tutorial Properties (or press Alt + F7), click on Configuration Properties, and change Output Directory from "$(SolutionDir)$(Configuration)\" to just "$(SolutionDir)" (without quotes of course).

I am not using the new VS2010 project files that have been recently added to the SDK, so this might already be fixed if you use that (though it seems like you would be already).
12-10-2010 10:03 PM
Find all posts by this user Quote this message in a reply
ArmyOfTwo Offline
Member

Post: #8
RE: starting?
I don't have Output Directory there
(This post was last modified: 12-11-2010 11:21 AM by ArmyOfTwo.)
12-11-2010 11:20 AM
Find all posts by this user Quote this message in a reply
Driklyn Offline
Member

Post: #9
RE: starting?
Make sure you have a .cpp file open first ("00 - Start.cpp", for instance).

-----
Edit: I just built and debugged a tutorial using the "Tutorials VS 2010.sln" project and the "Unable to start program" error didn't occur.
(This post was last modified: 12-12-2010 01:49 AM by Driklyn.)
12-12-2010 12:21 AM
Find all posts by this user Quote this message in a reply
Post Reply