About Store Forum Documentation Contact
Donations:
327$/mo



Post Reply 
bump/normal problem
Author Message
Nark100 Offline
Member

Post: #1
bump/normal problem
hey,
i got a problem with the normal map creation. whenever i click "make bump" it creates a black image instead of a proper normal map. any reason why this would happen?
12-12-2010 11:34 AM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #2
RE: bump/normal problem
I have sometimes this problem too.
12-12-2010 01:43 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #3
RE: bump/normal problem
Can you attach sample mtrl+gfx textures before "make bump", that after enabling this button you get black textures, so I could check them?
12-12-2010 01:53 PM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #4
RE: bump/normal problem
Here is my files.


Attached File(s)
.rar  Test.rar (Size: 150.21 KB / Downloads: 4)
12-12-2010 06:47 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #5
RE: bump/normal problem
I've tested this on dx9 and dx10 but I dont have black textures.
Are you using latest engine version?
12-12-2010 06:54 PM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #6
RE: bump/normal problem
Yes, and the latest drivers etc.
(This post was last modified: 12-12-2010 07:56 PM by Harry.)
12-12-2010 07:53 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Nark100 Offline
Member

Post: #7
RE: bump/normal problem
these are my mtrl file and gfx before the bump creation. as far as i can tell its not even making the bump gfx file and its only done it since i updated to the december release a few days ago.
also is there a way to use custom normal maps rather than allowing the editor to create them?


Attached File(s)
.rar  rock.rar (Size: 152.69 KB / Downloads: 3)
(This post was last modified: 12-13-2010 07:33 AM by Nark100.)
12-13-2010 07:15 AM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #8
RE: bump/normal problem
(12-13-2010 07:15 AM)Nark100 Wrote:  also is there a way to use custom normal maps rather than allowing the editor to create them?

Yes. Just drag and drop color and normal map together on material editor window.
12-13-2010 10:09 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Nark100 Offline
Member

Post: #9
RE: bump/normal problem
hmmm not working. i cant seem to get anything in the normal map slot without pressing the bump button, it dosnt have to be in any specific format?
12-13-2010 10:29 AM
Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #10
RE: bump/normal problem
.gfx(EE gfx), .tga, .dds atleast works
12-13-2010 10:36 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #11
RE: bump/normal problem
(12-13-2010 07:15 AM)Nark100 Wrote:  also is there a way to use custom normal maps rather than allowing the editor to create them?
check the documentation for applying materials carefully.
12-13-2010 11:18 AM
Find all posts by this user Quote this message in a reply
Nark100 Offline
Member

Post: #12
RE: bump/normal problem
ok so heres the thing. i can create normals with the bump button when the files are in a folder other than my DATA folder so im assuming it has something to do with permissions and folder attributes............... hmmmm
12-13-2010 11:24 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #13
RE: bump/normal problem
Thanks!

Now I see the problem, I'll fix it asap.
12-13-2010 11:30 AM
Find all posts by this user Quote this message in a reply
Nark100 Offline
Member

Post: #14
RE: bump/normal problem
ahh cool got the custom norms. forgot to profix them....
12-13-2010 11:30 AM
Find all posts by this user Quote this message in a reply
Harry Offline
Member

Post: #15
RE: bump/normal problem
It works now great smile Thanks for solving our problem smile
12-13-2010 07:43 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply