About Store Forum Documentation Contact
Donations:
243$/mo



Post Reply 
Problem with installing in VC Express 10
Author Message
devdude Offline
Member

Post: #1
Problem with installing in VC Express 10
Ok attempted installation twice. The first time it went smoothly and I was able to compile a tutorial and run it first try.

So I need to update the engine. I grab it and on the first step
" * Please copy folder "EsenthelEngineSDK\Installation\EsenthelEngine" to "Microsoft Visual Studio\VC\include" it fails. There is a folder named memory already there.

c:\Program Files(x86)\Microsoft Visual Studio 10.0\VC\include contains a header file named memory, preventing the EE directory memory from being created.

The content of the memory file is
Quote: // memory standard header
#pragma once
#ifndef _MEMORY_
#define _MEMORY_
#ifndef RC_INVOKED
#include <xmemory>

#pragma pack(push,_CRT_PACKING)
#pragma warning(push,3)

...

So, I can't continue past step 1 because it can't create a directory named memory. I just can't see what I am doing wrong here... I wonder if I grabbed the wrong engine source ?
01-22-2011 06:26 AM
Find all posts by this user Quote this message in a reply
Dandruff Offline
Member

Post: #2
RE: Problem with installing in VC Express 10
I might have misunderstood you, but try to manually make a new folder called EsenthelEngine in
Code:
"D:\Applications\Microsoft Visual Studio 2008\VC\include\"
then go in your "EsenthelEngineSDK\Installation\EsenthelEngine" and copy everything inside and throw it in the folder you just made
Code:
"D:\Applications\Microsoft Visual Studio 2008\VC\include\EsenthelEngine"
The memory folder of EE should be here
Code:
"D:\Applications\Microsoft Visual Studio 2008\VC\include\EsenthelEngine\Memory"

This way, all folders and files that belongs to Esenthel is in its own neat little folder so as to avoid conflicting file names and the like.

edit: i read it over again and if it is the autoupdater that is saying this, you might have put the wrong visual studio path. I have it set to "D:\Applications\Microsoft Visual Studio 2008\"
(This post was last modified: 01-22-2011 07:06 AM by Dandruff.)
01-22-2011 06:57 AM
Find all posts by this user Quote this message in a reply
devdude Offline
Member

Post: #3
RE: Problem with installing in VC Express 10
That sounds like the problem. I looked at having the wrong directory, but at the parent level. Thank you for the quick help. You'd make Todd Witteles proud.
01-22-2011 07:07 AM
Find all posts by this user Quote this message in a reply
Dandruff Offline
Member

Post: #4
RE: Problem with installing in VC Express 10
(01-22-2011 07:07 AM)devdude Wrote:  You'd make Todd Witteles proud.

Ahaha, Dan Druff grin You're welcome!
01-22-2011 07:17 AM
Find all posts by this user Quote this message in a reply
devdude Offline
Member

Post: #5
RE: Problem with installing in VC Express 10
Anyone know how to get output strings ? I am seeing that cout and cerr don't map to the Debug Output window.. I tried OutputDebugString but when I include those headers I get errors. cout/cerr work at compilation but I fail to see their output.

Got code working, now it is time to butcher it, but I have to learn it a bit first.
01-23-2011 07:16 AM
Find all posts by this user Quote this message in a reply
Dandruff Offline
Member

Post: #6
RE: Problem with installing in VC Express 10
Try to use DebugView and see if it finds anything


http://technet.microsoft.com/en-us/sysin...s/bb896647
(This post was last modified: 01-23-2011 07:45 AM by Dandruff.)
01-23-2011 07:39 AM
Find all posts by this user Quote this message in a reply
devdude Offline
Member

Post: #7
RE: Problem with installing in VC Express 10
No luck with that. I think that's probably the same as the Debug output in VC. Which needs OutputDebugString, which needs headers which stomp on the EE headers. I even tried running it from a console writing to both cout and cerr with no luck. !@#*($& windows programming.

Basically I want to just see hwo values of things change in the game loop... The debugger sucks for this.
01-23-2011 09:06 AM
Find all posts by this user Quote this message in a reply
Driklyn Offline
Member

Post: #8
RE: Problem with installing in VC Express 10
01-23-2011 09:37 AM
Find all posts by this user Quote this message in a reply
devdude Offline
Member

Post: #9
RE: Problem with installing in VC Express 10
(01-23-2011 09:37 AM)Driklyn Wrote:  http://www.esenthel.com/community/showth...light=cout

Cool, able to use cout instead of printf type output AND I get a nice debug window. Thanks guys. Guess I should do more searching on here, just not all that many threads.
01-23-2011 10:09 AM
Find all posts by this user Quote this message in a reply
Post Reply