About Store Forum Documentation Contact
Donations:
345$/mo



Post Reply 
Problems splitting up single track animations
Author Message
Brad_Mclain Offline
Member

Post: #1
Problems splitting up single track animations
I have been in the process of splitting up single track animations using the Clip options in the animations menu however sometimes I am running into problems.

I think (not 100% sure) it has to do with not all bones having a key-frame set for every frame, so when I clip in the middle of the animation it becomes all mangled. My reasoning for this is that it seems to always work fine for the first section perfectly.

Is there a way to set a key-frame for all bones in their current position/orientation?

This way I could do this at the start and end of each section before I do the clip.

I tried using the option "Add Empty Orientation Keyframe to all bones" but this did nothing and I am not entirely sure it's what I am after anyway.

It is also possible that something else is wrong and in that case I have no idea. Any help would be much appreciated.


Attached File(s) Image(s)
   
09-11-2011 12:51 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Dandruff Offline
Member

Post: #2
RE: Problems splitting up single track animations
off topic but, "becomes all mangled." lol, i had to laugh there. It does look pretty uncomfortable smile
09-11-2011 06:31 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #3
RE: Problems splitting up single track animations
You could attach mesh skeleton anim files
09-12-2011 08:50 AM
Find all posts by this user Quote this message in a reply
Brad_Mclain Offline
Member

Post: #4
RE: Problems splitting up single track animations
I'm not quite sure what you mean, could you please elaborate.

Edit: I am with you now, had a brain fade. I will PM/email them to you shortly smile
(This post was last modified: 09-12-2011 09:48 AM by Brad_Mclain.)
09-12-2011 09:38 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #5
RE: Problems splitting up single track animations
thanks, I've received the files, will check soon
09-12-2011 04:28 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #6
RE: Problems splitting up single track animations
Hi,
Can you tell me the range of the animation that you're trying to clip and have problems? (from-to)
You can also try specifying animation range in the 3ds max during exporting.
09-16-2011 11:32 AM
Find all posts by this user Quote this message in a reply
Brad_Mclain Offline
Member

Post: #7
RE: Problems splitting up single track animations
I have emailed the original file and animation information. The problem animation was "Dissapointed" frames 101-206.
09-16-2011 11:39 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #8
RE: Problems splitting up single track animations
I've found a small bug that may display the animation incorrectly after clipping, this will be fixed for next sdk.
09-16-2011 11:42 AM
Find all posts by this user Quote this message in a reply
Brad_Mclain Offline
Member

Post: #9
RE: Problems splitting up single track animations
Thanks latest SDK has fixed the problem. smile
Update: seems that I am still having some issues when using a different model.

I have emailed it to you so you can see for yourself.
(This post was last modified: 09-17-2011 03:07 AM by Brad_Mclain.)
09-17-2011 02:13 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #10
RE: Problems splitting up single track animations
will work correctly in next sdk smile
(about multiple animation tracks from the e-mail: collada doesn't support this)
09-18-2011 02:04 PM
Find all posts by this user Quote this message in a reply
Post Reply