About Store Forum Documentation Contact
Donations:
327$/mo



Post Reply 
Disappearing particles
Author Message
Nox_A15 Offline
Member

Post: #1
Disappearing particles
Today I encountered a problem with rendering particles during testing the map with World Editor (moving around with obj_player object). I wanted to create a quite big wall from particles. They are huge and in the distance, fly for two seconds very quickly horizontally. Problem is, when I watch the particles with the camera, moving it also horizontally, there is an angle from which they disappear and are not rendered at all. After moving camera back to previous position they appear again.

Strange thing is, everything is normal when working in the editor (not moving with obj_player). I haven't tested if everything is all right when playing in our exe.
12-27-2011 05:18 AM
Find all posts by this user Quote this message in a reply
fatcoder Offline
Member

Post: #2
RE: Disappearing particles
Maybe the emitter is going outside the view frustum, which is culling away the entire particle system???
12-27-2011 02:55 PM
Find all posts by this user Quote this message in a reply
aceio76 Offline
Silver Supporter

Post: #3
RE: Disappearing particles
Is this using a custom Particle object? I don't recall the default particle object using Frustum culling...

www.thinkplaystudios.com
12-27-2011 08:19 PM
Visit this user's website Find all posts by this user Quote this message in a reply
fatcoder Offline
Member

Post: #4
RE: Disappearing particles
I haven't used particles much in EE yet, so I was just taking a stab. It would seem silly if the default particle system didn't use frustum culling??? You could end up with so many outside the view, being updated and rendered for no reason.
12-27-2011 11:18 PM
Find all posts by this user Quote this message in a reply
aceio76 Offline
Silver Supporter

Post: #5
RE: Disappearing particles
Agreed smile

www.thinkplaystudios.com
12-28-2011 01:33 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Nox_A15 Offline
Member

Post: #6
RE: Disappearing particles
Thanks for help guys. smile I've just checked and yes, you're right - particles disappear when the source is not on the screen any longer. It still has some "buffer" though (area around the source that prevent it from disappearing too early), so with smaller particles it's probably not even possible to encounter this issue. Problem is, my particles are huge and they traverse quite a distance horizontally from the source.

Now, how to cheat the engine for it not to erase them from the screen? I've just tried to apply a huge physics to the particle object or to change the size of the object, nothing helps. I found out that particles disappear even when camera still see the object box (huge one, but still). Any suggestions?

I would love to have a choice - "those particles will be visible all the time until I say otherwise". Or maybe some LoD-like distance system would be better - they would disappear after chosen distance from the camera.
12-28-2011 08:30 PM
Find all posts by this user Quote this message in a reply
Post Reply