About Store Forum Documentation Contact
Donations:
289$/mo



Post Reply 
code editor doesn't use correct VS version
Author Message
yvanvds Offline
Silver Supporter

Post: #1
code editor doesn't use correct VS version
I tried to compile the tutorial examples for the code editor today. It doesn't work here. Here's what I did.

When I choose play, a progress bar in the upper right appears and stays at 20%. Nothing happens in the output window. The source files get created in _C++ Build_ though.

When I try 'Debug', VS just opens the Project.vcxproj file. It hints that some elements, like AdditionOptions and InlineFunctionExpansion are wrong. After a while i get a VS dialog box telling me "Invalid license data. Reinstall is required."

When I choose "open in visual studio" I get this dialog right away.

I am using VS2010 express and the license is ok. I can compile from within VS just fine.

A few other things that might have to do with it: I am using windows8 preview, and used to have VS2011 installed for a while. Perhaps it wrote some values to the registry that EE is not expecting?

I did reinstall VS and Esenthel, but that didn't help.

On my windows 7 laptop with VS2010 the tutorial compiles just fine. In both cased the visual studio path is set to C:\Program Files (x86)\Microsoft Visual Studio 10.0\, which seems ok.

Any ideas? (It's not urgent for me, I just wanted to check out the current status of the code editor.)

Regards,

yvan
06-25-2012 09:35 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: code editor doesn't use correct VS version
Hello, I think I would need to have Win8 installed to test this issue. But I'd prefer to wait until it's officially released to install it on my computer.
06-29-2012 02:40 PM
Find all posts by this user Quote this message in a reply
yvanvds Offline
Silver Supporter

Post: #3
RE: code editor doesn't use correct VS version
You might want to know that the issue solved itself with the official release of windows 8. Just tested it and all is ok.
10-28-2012 01:14 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: code editor doesn't use correct VS version
Thank you, that's one of the reasons I don't like to support unreleased/beta platforms yet smile
11-07-2012 04:32 PM
Find all posts by this user Quote this message in a reply
Post Reply