About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Trouble with single particle (not reborn)
Author Message
Rollcage Offline
Member

Post: #1
Trouble with single particle (not reborn)
I can get a particle to display when it has "reborn" checked, however I only want it to display once. If I uncheck reborn then It doesn't display at all. What is the correct procedure for playing a single particle effect? Should I delete it after it has finished aswell? Would this just be done through the update function checking how much life it has left and then calling delete()?

I haven't tried setting the particle to "reborn" and then setting reborn to false as soon as I create it.

Thanks
10-17-2012 02:36 AM
Find all posts by this user Quote this message in a reply
fatcoder Offline
Member

Post: #2
RE: Trouble with single particle (not reborn)
I was going to start a new thread, but found this unanswered one. I too have come across the same problem. I think reborn might be broken as setting it to false causes the particle effect to stop working completely (i.e. it won't even run once).

For example, open the Particles tutorial and add the following to the first particle effect, before the reset() call.

Code:
particle[0].reborn = false;

Shouldn't this cause the particle effect to play once and then stop, until reset() is called again? If so, then this is not the case, so there could be a bug here? I also tried setting life_total to something other than 0.0f but that also makes no difference.
01-23-2013 09:49 AM
Find all posts by this user Quote this message in a reply
fatcoder Offline
Member

Post: #3
RE: Trouble with single particle (not reborn)
On news on this issue?
01-30-2013 02:57 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Trouble with single particle (not reborn)
you can try setting reborn to false after calling 'reset'
02-03-2013 12:27 PM
Find all posts by this user Quote this message in a reply
Post Reply