About Store Forum Documentation Contact
Donations:
158$/mo



Post Reply 
tutorial build error
Author Message
Ashaira Offline
Member

Post: #1
tutorial build error
every time i try to run a tutorial i get wa warning saying that tutorial.exe was not found or the debugigng information does not match and if i click continue i get an error saying can't create directinput. Any help would be apreciated
05-21-2009 12:57 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
Re: tutorial build error
maybe you have some compiling/linking errors

check the Visual Studio output window when compiling
05-21-2009 01:00 PM
Find all posts by this user Quote this message in a reply
Ashaira Offline
Member

Post: #3
Re: tutorial build error
this is what it says after it gives me the directinput error : The thread 'Win32 Thread' (0x1080) has exited with code -1 (0xffffffff).
The thread 'Win32 Thread' (0x1458) has exited with code -1 (0xffffffff).
The thread 'Win32 Thread' (0x16fc) has exited with code -1 (0xffffffff).
The thread 'Win32 Thread' (0x123c) has exited with code -1 (0xffffffff).
The program '[5764] Tutorials.exe: Native' has exited with code -1 (0xffffffff).
05-21-2009 01:45 PM
Find all posts by this user Quote this message in a reply
Ashaira Offline
Member

Post: #4
Re: tutorial build error
oh i just tested the rest of the tools and i get the same error for all of them: can't create direct input.
could it have something to do with the fact that im using a laptop? i know the laptop video drivers are a pain compared to the normal ones
05-21-2009 01:49 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #5
Re: tutorial build error
Quote:could it have something to do with the fact that im using a laptop?
maybe,
but most importantly - do you have installed the latest DirectX runtime?
please try this - <!-- m --><a class="postlink" href="http://www.microsoft.com/downloads/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en">http://www.microsoft.com/downloads/deta ... laylang=en</a><!-- m -->
05-21-2009 01:53 PM
Find all posts by this user Quote this message in a reply
Ashaira Offline
Member

Post: #6
Re: tutorial build error
well i installed the one that ur site had a link too but im gona try the one u said hopefully its gona work
05-21-2009 02:11 PM
Find all posts by this user Quote this message in a reply
Ashaira Offline
Member

Post: #7
Re: tutorial build error
unfortunatelly i still get the exact same error :( ill try it on my home pc when i get home in a month or so but thnx a lot for the rapid response really apreciate it
05-21-2009 05:33 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #8
Re: tutorial build error
Sorry to hear that.

According to the error "can't create direct input" it means that the system must have some issue in detecting the direct input (keyboard and mouse - these are required to run the engine).
05-21-2009 06:21 PM
Find all posts by this user Quote this message in a reply
Serg_FD Offline
Member

Post: #9
Re: tutorial build error
I have the same error I don't use laptop and my PC & video are very powerful,

The thread 'Win32 Thread' (0xeac) has exited with code -1 (0xffffffff).
The thread 'Win32 Thread' (0xa3c) has exited with code -1 (0xffffffff).
The thread 'Win32 Thread' (0xd40) has exited with code -1 (0xffffffff).
The thread 'Win32 Thread' (0xd30) has exited with code -1 (0xffffffff).
The thread 'Win32 Thread' (0xe70) has exited with code -1 (0xffffffff).
The program '[2984] Tutorials.exe: Native' has exited with code -1 (0xffffffff).

Can't Load effect "Main"
[Image: 2CSGJrRxN1.jpg]

help if you can :shock:
08-09-2009 11:13 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #10
Re: tutorial build error
is this your custom project? maybe youre using incorrect version of engine.pak file
08-09-2009 11:15 PM
Find all posts by this user Quote this message in a reply
Serg_FD Offline
Member

Post: #11
Re: tutorial build error
Esenthel Wrote:is this your custom project? maybe youre using incorrect version of engine.pak file

no this is tutorial and any tutorial don't work, I install SDK march 2009 and install correctly your Engine and it don't work to the great distressing.
08-10-2009 09:21 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #12
Re: tutorial build error
but EE doesnt require directx sdk march 2009, but november 2008 SDK
<!-- m --><a class="postlink" href="http://www.esenthel.com/wiki/index.php?title=Engine_Installation#DirectX_SDK">http://www.esenthel.com/wiki/index.php? ... irectX_SDK</a><!-- m -->
the directX runtime can be free (march 2009 or november 2008)

please make sure that you have the latest drivers for your graphics card

if it still doesnt work please let me know the model of your video card, OS, and video driver version, and amount of ram, and cpu.
08-10-2009 06:20 PM
Find all posts by this user Quote this message in a reply
Serg_FD Offline
Member

Post: #13
Re: tutorial build error
Esenthel Wrote:but EE doesnt require directx sdk march 2009, but november 2008 SDK
<!-- m --><a class="postlink" href="http://www.esenthel.com/wiki/index.php?title=Engine_Installation#DirectX_SDK">http://www.esenthel.com/wiki/index.php? ... irectX_SDK</a><!-- m -->
the directX runtime can be free (march 2009 or november 2008)

please make sure that you have the latest drivers for your graphics card

if it still doesnt work please let me know the model of your video card, OS, and video driver version, and amount of ram, and cpu.
Many thanks for you, november 2008 SDK help with this problem and all is ok now -- THANKS pfft pfft pfft
08-10-2009 09:15 PM
Find all posts by this user Quote this message in a reply
Post Reply