About Store Forum Documentation Contact
Donations:
327$/mo



Post Reply 
Minimum shader requirement ?
Author Message
Juggernaut Offline
Member

Post: #1
Minimum shader requirement ?
Hello Esenthel,

What is the minimum shader model requirement for the Esenthel 2.0 engine games to run on a Windows PC ?

Is shader model 2.0 good enough to run the games made with Esenthel 2.0 engine ? Will it limit some rendering features ? If so, then what features will be unusable on a SM 2.0 supported GPU ?

Will games made with Esenthel engine 2.0 run on video chips that do not support any shader model or SM 1.0 ?

Thanks,
09-06-2013 02:32 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Minimum shader requirement ?
Hi, minimum is 2.0, yes it will have some things disabled, like automatic filtering of shadows, or relief bump mapping. I don't remember about other things, but most will work the same, it's like 99% works.
09-07-2013 01:30 AM
Find all posts by this user Quote this message in a reply
Juggernaut Offline
Member

Post: #3
RE: Minimum shader requirement ?
(09-07-2013 01:30 AM)Esenthel Wrote:  Hi, minimum is 2.0, yes it will have some things disabled, like automatic filtering of shadows, or relief bump mapping. I don't remember about other things, but most will work the same, it's like 99% works.

Will it be automatic ? I mean if I am using shadow mapping or relief bum mapping and then the host GPU running the game only support SM 2.0 of DirectX , will there be any run-time error thrown by the Esenthel Engine 2.0 that I will have to handle on my own by writing custom code ?
09-07-2013 04:53 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Minimum shader requirement ?
Hi!
EE Will not throw any errors in that case, it will just use simpler effects, so no worries smile
09-09-2013 08:15 AM
Find all posts by this user Quote this message in a reply
Post Reply