About Store Forum Documentation Contact
Donations:
178$/mo



Post Reply 
[SOLVED]can't publish my apps after update
Author Message
andrake Offline
Member

Post: #1
[SOLVED]can't publish my apps after update
with previous version all will be ok and now i get this android log:

Code:
Time(05:48:09), App(dzy): userActivity
Time(05:48:09), App(ActivityManager): START {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=com.andrake.happy_turtle_test1/.EsenthelActivity u=0} from pid 449
Time(05:48:09), App(dalvikvm): WAIT_FOR_CONCURRENT_GC blocked 0ms
Time(05:48:09), App(ActivityManager): Start proc com.andrake.happy_turtle_test1 for activity com.andrake.happy_turtle_test1/.EsenthelActivity: pid=12419 uid=10060 gids={1015, 3003, 1028}
Time(05:48:09), App(dalvikvm): WAIT_FOR_CONCURRENT_GC blocked 0ms
Time(05:48:09), App(dalvikvm): WAIT_FOR_CONCURRENT_GC blocked 0ms
Time(05:48:09), App(Trace): error opening trace file: No such file or directory (2)
Time(05:48:09), App(dalvikvm): dvmFindClassByName rejecting 'com.andrake.happy_turtle_test1/EsenthelActivity$EsenthelLocationListener'
Time(05:48:09), App(dalvikvm): Trying to load lib /data/data/com.andrake.happy_turtle_test1/lib/libProject.so 0x41f434f8
Time(05:48:09), App(dalvikvm): Added shared lib /data/data/com.andrake.happy_turtle_test1/lib/libProject.so 0x41f434f8
Time(05:48:09), App(dalvikvm): No JNI_OnLoad found in /data/data/com.andrake.happy_turtle_test1/lib/libProject.so 0x41f434f8, skipping init
Time(05:48:09), App(Finsky): [86] InAppBillingUtils.pickAccount: com.andrake.happy_turtle_test1: Account determined from installer data - [iDVFFQwcm2Ztg49J1eCLENrvrPQ]
Time(05:48:09), App(Finsky): [115] InAppBillingUtils.pickAccount: com.andrake.happy_turtle_test1: Account determined from installer data - [iDVFFQwcm2Ztg49J1eCLENrvrPQ]
Time(05:48:09), App(libOpenSLES): class OutputMix interface 0 requested but unavailable MPH=28
Time(05:48:09), App(libOpenSLES): Leaving Engine::CreateListener (SL_RESULT_FEATURE_UNSUPPORTED)
Time(05:48:09), App(libEGL): loaded /system/lib/egl/libEGL_mali.so
Time(05:48:09), App(libEGL): loaded /system/lib/egl/libGLESv1_CM_mali.so
Time(05:48:09), App(ActivityManager): Displayed com.andrake.happy_turtle_test1/.EsenthelActivity: +222ms
Time(05:48:09), App(libEGL): loaded /system/lib/egl/libGLESv2_mali.so
Time(05:48:11), App(Esenthel): Can't load Image "dmpas54pglc4!-#q15o2saxn"
Time(05:48:11), App(WindowState): WIN DEATH: Window{42305df8 com.andrake.happy_turtle_test1/com.andrake.happy_turtle_test1.EsenthelActivity paused=false}
Time(05:48:11), App(ActivityManager): Process com.andrake.happy_turtle_test1 (pid 12419) has died.
Time(05:48:11), App(Zygote): Process 12419 exited cleanly (255)
Time(05:48:11), App(ActivityManager): Force removing ActivityRecord{42218fb8 com.andrake.happy_turtle_test1/.EsenthelActivity}: app died, no saved state
Time(05:48:11), App(InputMethodManagerService): Got RemoteException sending setActive(false) notification to pid 12419 uid 10060
Time(05:49:10), App(net.thoster.noteshare.messaging.MessageReceiver): SchedulerEventReceiver.onReceive() called
Time(05:49:10), App(net.thoster.noteshare.messaging.MessageService): MessageService started!
Time(05:50:26), App(GTalkService): [DataMsgMgr] broadcast intent callback: result=CANCELLED forIntent { act=com.google.android.c2dm.intent.RECEIVE pkg=com.instagram.android (has extras) }
Time(05:50:26), App(GTalkService): Receiver package not found, unregister application com.instagram.android sender instagramandroidmarket@gmail.com
Time(05:50:26), App(GCM): GCM config loaded
Time(05:51:10), App(net.thoster.noteshare.messaging.MessageReceiver): SchedulerEventReceiver.onReceive() called
Time(05:51:10), App(net.thoster.noteshare.messaging.MessageService): MessageService started!

in windows all runs ok. picture that it can found not presented in project at all
(This post was last modified: 04-30-2014 02:31 PM by andrake.)
04-29-2014 05:44 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: can't publish my apps after update
Could you tell me which Esenthel License do you own? (I don't see any in your Forum User Title).
And which update are you talking about?
Thank you
04-30-2014 05:19 AM
Find all posts by this user Quote this message in a reply
andrake Offline
Member

Post: #3
RE: can't publish my apps after update
Binary Monthly Subscription(andrake16@gmail.com)
i think it can't run on android after 04-27-2014 05:24 AM update

i was updated yesterday(29apr)

i try to publish and run my current project and there i can't see personages models(http://www.esenthel.com/community/showth...p?tid=7708) then i try to publish and run my previous project and it can't run on android at all.
(This post was last modified: 04-30-2014 06:49 AM by andrake.)
04-30-2014 06:46 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: can't publish my apps after update
Did you paste the "dmpas54pglc4!-#q15o2saxn" to the project search box to see if you still have it?
It looks like you've removed that Image.
04-30-2014 07:41 AM
Find all posts by this user Quote this message in a reply
andrake Offline
Member

Post: #5
RE: can't publish my apps after update
in Windows project directory file with this name is presented(i open it ..first symbols is GFX....) , but in EE image with this id is not presented(i check every image).
should i check every material for link to this image?

main question is why it runs on windows platform but not on android. why windows platform don't say to me: this file is absent but used there and there?

also i made "clean all" before build and run
(This post was last modified: 04-30-2014 08:23 AM by andrake.)
04-30-2014 08:22 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: can't publish my apps after update
This means you're trying to access an image "dmpas54pglc4!-#q15o2saxn" that you've removed.

The file could still be there if you haven't done "erase removed elements"
04-30-2014 08:31 AM
Find all posts by this user Quote this message in a reply
andrake Offline
Member

Post: #7
RE: can't publish my apps after update
yes after erase removed elements windows show to me the same message..will be investigated

but really how can i found place where it used?

ok.found it in code. it was shown as UID(xxx,xx,xx,xx) instead of path on blue background. thank you. Solved
(This post was last modified: 04-30-2014 02:30 PM by andrake.)
04-30-2014 02:21 PM
Find all posts by this user Quote this message in a reply
MrPi Offline
Member

Post: #8
RE: [SOLVED]can't publish my apps after update
To make that easier especially for beginners, would it be too hard to display the name in that error message instead, Greg? I know we can convert the name by writing a few lines of code, but I think displaying the name there is much more useful.
(This post was last modified: 05-01-2014 09:37 AM by MrPi.)
05-01-2014 09:36 AM
Find all posts by this user Quote this message in a reply
Rubeus Offline
Member

Post: #9
RE: [SOLVED]can't publish my apps after update
Doesn't the asset need to exist for it to look up the name from it?
05-01-2014 02:08 PM
Find all posts by this user Quote this message in a reply
Post Reply