About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Editor cannot display Chinese character properly
Author Message
flim Offline
Member

Post: #1
Editor cannot display Chinese character properly
I am using Chinese Windows 8.1. I use the latest EE demo version. Some save txt dialog, and the output windows cannot display Chinese Character properly. I tried to change the non-unicode setting in Control Panel but the problem still exists.

The output like this:
Quote:E:\Esenthel\Projects\_Build_\1 - Basic App\Project.vcxproj : warning : ?????? '1 - Basic App' ?????? 'Emscripten'?
1>------ ?????: ??: 1 - Basic App, ??: Debug DX10+ x64 ------
1> Commands.cpp
1> Main.cpp
1> ???????...
1> Project.vcxproj -> E:\Esenthel\Projects\_Build_\1 - Basic App\1 - Basic App.exe
========== ??: 1 ???0 ???0 ???0 ?? ==========
08-13-2014 09:57 AM
Find all posts by this user Quote this message in a reply
Houge Offline
Silver Supporter

Post: #2
RE: Editor cannot display Chinese character properly
The same was here with russian chars
http://www.esenthel.com/community/showth...8#pid45368
08-13-2014 11:32 AM
Visit this user's website Find all posts by this user Quote this message in a reply
flim Offline
Member

Post: #3
RE: Editor cannot display Chinese character properly
[quote='flim' pid='48161' dateline='1407933755']
I have EE 1.0 and upgrade to 2.0 a year ago, but didn't use it because I have some other priorities. Now I want to start making games and I come back to EE and found the licensing was change to subscription based.

I will be more expensive to use so I look into it more carefully. The first thing I found was support of non-English character is very poor.

Is it EE does not support unicode, or lack of appropriate fonts? All file dialogs cannot show non-English files & folders.

Just found this thread discussing the same issue, it seems there is no timeframe for the fix.
http://www.esenthel.com/community/showth...292&page=2
(This post was last modified: 08-13-2014 05:20 PM by flim.)
08-13-2014 05:16 PM
Find all posts by this user Quote this message in a reply
Houge Offline
Silver Supporter

Post: #4
RE: Editor cannot display Chinese character properly
No, Visual Studio output (at least russian VS) is in CP866 / OEM866 codepage.
Try to save output from Visual Studio like Greg wrote here and try to find out what codepage is used. I think that's what we need to find out now.

(08-13-2014 05:16 PM)flim Wrote:  I will be more expensive to use so I look into it more carefully. The first thing I found was support of non-English character is very poor.

Is it EE does not support unicode, or lack of appropriate fonts? All file dialogs cannot show non-English files & folders.

That should be fine, you need to use a font that includes chinese letters (there is a checkbox in font creation dialog).
(This post was last modified: 08-13-2014 06:58 PM by Houge.)
08-13-2014 06:55 PM
Visit this user's website Find all posts by this user Quote this message in a reply
flim Offline
Member

Post: #5
RE: Editor cannot display Chinese character properly
The most annoying problem is the EE file dialogs cannot show non-English file and folder name. How can I add font to EE by myself?

For the strange output windows, I guess installing English version can get rid of the ??? garbage.
08-14-2014 07:43 AM
Find all posts by this user Quote this message in a reply
Houge Offline
Silver Supporter

Post: #6
RE: Editor cannot display Chinese character properly
(08-14-2014 07:43 AM)flim Wrote:  The most annoying problem is the EE file dialogs cannot show non-English file and folder name.

Can you show an example (screenshot) of such dialog?
(This post was last modified: 08-14-2014 09:26 AM by Houge.)
08-14-2014 09:26 AM
Visit this user's website Find all posts by this user Quote this message in a reply
flim Offline
Member

Post: #7
RE: Editor cannot display Chinese character properly
[Image: EE.jpg]

You can see EE cannot show Chinese character, I believe all CJK Windows cannot show the file name.

If it is font issue, how can I install font in EE editor?
08-14-2014 12:13 PM
Find all posts by this user Quote this message in a reply
Houge Offline
Silver Supporter

Post: #8
RE: Editor cannot display Chinese character properly
In that case you need to wait for Greg to answer...
08-14-2014 12:39 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #9
RE: Editor cannot display Chinese character properly
Hi,

Displaying Chinese fonts in Code Editor is supported:
https://www.facebook.com/EsenthelEngine/...nt_count=1

However Visual Studio output is a different thing, as Houge noted I would need to have direct output of Visual Studio so we can figure out what's wrong. (this applies to the "Output" region in EE)
If you provide necessary file/output then I can investigate this for free.

As for file Dialogs, the Chinese characters do work correctly, however the main font in Esenthel does not have Chinese characters included because then the editor package would be much bigger. (Chinese characters use a lot of space).
The solution would be to add an option in the Editor to dynamically generate/customize the font in the Editor.
If you'd like me to add this option in first priority, I can do it for 50$.

Thanks
08-15-2014 03:59 AM
Find all posts by this user Quote this message in a reply
flim Offline
Member

Post: #10
RE: Editor cannot display Chinese character properly
I don't have devenv because my VS is 2013 express.

There is WDExpress in IDE folder, I build the sln with /out, here is the output.

Quote:E:\Esenthel\Projects\_Build_\1 - Basic App\Project.vcxproj : warning : 找不到專案檔 '1 - Basic App' 中參考的平台 'Emscripten'。

'1 - Basic App.exe' (Win32): 已載入 'E:\Esenthel\Projects\_Build_\1 - Basic App\1 - Basic App.exe'。已載入符號。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\ntdll.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\kernel32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\KernelBase.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\d3d9.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\D3DX9_42.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\xinput1_3.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\dinput8.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\dsound.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\winmm.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\ws2_32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\imm32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\psapi.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\rpcrt4.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\version.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\IPHLPAPI.DLL'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\setupapi.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\user32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\gdi32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\advapi32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\shell32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\ole32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\oleaut32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\odbc32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\msvcrt.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\sechost.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\dwmapi.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\powrprof.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\winmmbase.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\nsi.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\msctf.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\sspicli.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\winnsi.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\cfgmgr32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\combase.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\shlwapi.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\devobj.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\cryptbase.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\bcryptprimitives.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\kernel.appcore.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\uxtheme.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\PROGRA~2\Raptr\ltc_help32-85743.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\wintrust.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\crypt32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\msasn1.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\dhcpcsvc.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\mswsock.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\dnsapi.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Program Files (x86)\Bonjour\mdnsNSP.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\clbcatq.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\ExplorerFrame.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\duser.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\dui70.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\SHCore.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\MMDevAPI.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\AudioSes.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\hid.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\ntmarta.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\wbem\wbemprox.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\wbemcomn.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\cryptsp.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\rsaenh.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\bcrypt.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\wbem\wbemsvc.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\wbem\fastprox.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\aticfx32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiu9pag.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiu9pag.dll'
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiu9pag.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiumdag.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiumdva.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\igdumdim32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\igdusc32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiumdva.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiumdag.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiu9pag.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\aticfx32.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\igdusc32.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\igdumdim32.dll'
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\aticfx32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiu9pag.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiu9pag.dll'
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiu9pag.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiumdag.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\atiumdva.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\igdumdim32.dll'。找不到或無法開啟 PDB 檔案。
'1 - Basic App.exe' (Win32): 已載入 'C:\Windows\SysWOW64\igdusc32.dll'。找不到或無法開啟 PDB 檔案。
0x20290 執行緒以返回碼 0 (0x0) 結束。
0x1fc5c 執行緒以返回碼 0 (0x0) 結束。
0x2006c 執行緒以返回碼 0 (0x0) 結束。
0x1fc28 執行緒以返回碼 0 (0x0) 結束。
0x1fc98 執行緒以返回碼 0 (0x0) 結束。
0x2027c 執行緒以返回碼 0 (0x0) 結束。
0x1fdd4 執行緒以返回碼 0 (0x0) 結束。
0x20084 執行緒以返回碼 0 (0x0) 結束。
0x20380 執行緒以返回碼 0 (0x0) 結束。
0x1ffd0 執行緒以返回碼 0 (0x0) 結束。
0x1fcb0 執行緒以返回碼 0 (0x0) 結束。
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiumdva.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiumdag.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\atiu9pag.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\aticfx32.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\igdusc32.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\igdumdim32.dll'
0x202d8 執行緒以返回碼 0 (0x0) 結束。
0x1fff0 執行緒以返回碼 0 (0x0) 結束。
0x1fe3c 執行緒以返回碼 0 (0x0) 結束。
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\dnsapi.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\mswsock.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Program Files (x86)\Bonjour\mdnsNSP.dll'
0x20264 執行緒以返回碼 0 (0x0) 結束。
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\SHCore.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\dui70.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\duser.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\ExplorerFrame.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\wbem\fastprox.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\wbem\wbemsvc.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\wbemcomn.dll'
'1 - Basic App.exe' (Win32): 已卸載 'C:\Windows\SysWOW64\wbem\wbemprox.dll'
0x1ed00 執行緒以返回碼 0 (0x0) 結束。
0x1e644 執行緒以返回碼 0 (0x0) 結束。
0x1fc84 執行緒以返回碼 0 (0x0) 結束。
0x1fce4 執行緒以返回碼 0 (0x0) 結束。
0x22b0 執行緒以返回碼 0 (0x0) 結束。
'[129928] 1 - Basic App.exe' 程式以返回碼 0 (0x0) 結束。
08-15-2014 05:46 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #11
RE: Editor cannot display Chinese character properly
Hi,

Can you attach this as the raw file?
The file that gets generated, please ZIP/RAR it, and attach that file.

Thanks
08-16-2014 04:45 AM
Find all posts by this user Quote this message in a reply
flim Offline
Member

Post: #12
RE: Editor cannot display Chinese character properly
Here you are.


Attached File(s)
.zip  tcerror.zip (Size: 1.15 KB / Downloads: 4)
08-16-2014 05:35 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #13
RE: Editor cannot display Chinese character properly
Thanks, I'm uploading updated Editor now.
08-16-2014 06:47 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #14
RE: Editor cannot display Chinese character properly
This is now available, please let me know if the VS output works OK now.
08-16-2014 07:34 AM
Find all posts by this user Quote this message in a reply
flim Offline
Member

Post: #15
RE: Editor cannot display Chinese character properly
After applied the update the output window still not OK.

Attached is the output of EE.

My Windows is Chinese not Simplify Chinese.


Attached File(s)
.txt  Output.txt (Size: 437 bytes / Downloads: 13)
(This post was last modified: 08-16-2014 01:15 PM by flim.)
08-16-2014 01:14 PM
Find all posts by this user Quote this message in a reply
Post Reply