About Store Forum Documentation Contact
Donations:
207$/mo



Post Reply 
Multiplayer racing game
Author Message
cat555 Offline
Member

Post: #1
Multiplayer racing game
Hi, i've installed this game (directly from google play) for some time now... it usually ran Ok, but since the last update (April i think), the game just freezes... the race starts and randomly it freezes and can't play no more...

Unfortunately it doesn't dump any useful information (adb logcat)...

Can it be related somehow with EE3.0?

On some other tests i've been working with Esenthel, i also got some random freezes, but just not so often like in multiplayer racing game.

Any ideas?

By the way, i'm using Nexus 7 device.

Thanks!
08-13-2014 02:00 PM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #2
RE: Multiplayer racing game
Hi,

I've just played the game on my Galaxy Note 2 for 100 seconds in multiplayer mode against my Win laptop, and it had no issues.
08-15-2014 04:10 AM
Find all posts by this user Quote this message in a reply
cat555 Offline
Member

Post: #3
RE: Multiplayer racing game
Hi, thanks for your reply.

Well, i got the sources from the store, and i can repdroduce the same behavior. The race starts and almost in the first seconds the game freezes. I've tried in debug mode, but there is just a single line in logcat that's related with this freeze...

Can you give me some clue of how to debug this? I've already done the basics by commenting almost all the code by parts to find the part that lead to this issue, but nothing... i just can't find anything...

My android version is 4.4.4 at the moment.

The only debug messages i'm getting from logcat are logged when application is started:

Code:
D/libEGL  ( 4876): [glTexImage2D] 0x502
D/glGetError:glTexImage2D( 4876): #00  pc 00012aa4  /system/lib/libEGL.so
D/glGetError:glTexImage2D( 4876): #01  pc 00138f80  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #02  pc 00139178  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #03  pc 0013cfd8  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #04  pc 0013d10c  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #05  pc 0013d8dc  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #06  pc 0013d90e  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #07  pc 001b966e  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #08  pc 00150cd0  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #09  pc 00155b16  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #10  pc 001345f6  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #11  pc 00228c38  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #12  pc 0027c394  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #13  pc 006a298a  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #14  pc 0027bbe8  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #15  pc 006a25a2  /data/app-lib/com.esenthel.race-2/libProject.so
D/glGetError:glTexImage2D( 4876): #16  pc 0000d228  /system/lib/libc.so (__thread_entry+72)
D/glGetError:glTexImage2D( 4876): #17  pc 0000d3c0  /system/lib/libc.so (pthread_create+240)

But this also is shown when every Esenthel application is started, so it's not specific to this game.
08-18-2014 01:44 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Multiplayer racing game
Hi,

Since when have you started experiencing these problems?
Perhaps this is related to 4.4.4 Android.

My phone is on 4.3 and there's no update for my device anymore.
08-18-2014 03:25 AM
Find all posts by this user Quote this message in a reply
cat555 Offline
Member

Post: #5
RE: Multiplayer racing game
Hi,
I don't know exactly when started to happen, but i've done a bunch of tests now and this is happening all the time with this game... i've reproduced this behavior in other projects but the frequency is very low.

But finally i managed to find the cause... this only happens with the default world mode:

Code:
Game.World.mode(Game::WORLD_STREAM);

If i use

Code:
Game.World.mode(Game::WORLD_FULL);

the problem is gone...

The strange here is that i have other projects using WORLD_STREAM, and i don't have this problem happening with such a frequency.
08-18-2014 11:50 AM
Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #6
RE: Multiplayer racing game
Thanks,

This means that on your device loading assets on a secondary thread may cause issues.

I cannot investigate further without having a similar device to make tests.
08-19-2014 04:07 AM
Find all posts by this user Quote this message in a reply
cat555 Offline
Member

Post: #7
RE: Multiplayer racing game
Yes i understand... it seems to be related with 4.4.4 on this device... i remember that recently i didnt't have this issue.

Let's see the behavior on the next release of android... i'll update that information here when relevant.
08-21-2014 10:19 AM
Find all posts by this user Quote this message in a reply
Post Reply