About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Issues with Editor generated pathmesh
Author Message
KraaxLeNain Offline
Member

Post: #1
Issues with Editor generated pathmesh
Hey everyone,

I have in my world automatically generated the pathmesh from the editor... Problem is in Area junctions there is a high concentration of lines which cause some "band" outside of the pathmesh which should not exist, resulting on error when moving around in the world.

Picture enclose (clic to zoom, you can't see a thing on the compressed version).

[Image: mini_367761WeirdPathMesh.jpg]

Has anyone any idea on how to solve this ? Has anyone already encountered that ?

Thx for the help.

Nota : still on EE2.0, has there been changes in pathmesh generation in new version of EE.

Bonus question : can pathmesh be builded manually, either by code or direct correstion on the editor ?
(This post was last modified: 10-01-2014 08:27 AM by KraaxLeNain.)
09-30-2014 10:57 PM
Find all posts by this user Quote this message in a reply
gdalex Offline
Member

Post: #2
RE: Issues with Editor generated pathmesh
EE 1.0 had a painter to define and correct the pathmesh...
In my opinion that was a really efficient solution smile
10-01-2014 08:58 AM
Find all posts by this user Quote this message in a reply
KraaxLeNain Offline
Member

Post: #3
RE: Issues with Editor generated pathmesh
Hi again...

So I've watched closely the pathmesh in the tutorial and they seems to be quads while in my world they are triangles...

I think thsis might solve my issue because whith quads I expect the corner of area will not have that "millions triangle edge" problem.

Side problem is : how to force the editor in the map to use quads and not triangles ? I've seen I can manually create the path but I don't pretend to do it better on a full scale than the engine.

Code:
Bool create(MeshBase &mesh, C VecI2 &area_xy, C PathSettings &settings); // build path mesh from source 'mesh', at 'area_xy' area coordinates using 'settings' path build settings, false on fail ("mesh.tri.flag" and "mesh.quad.flag" can be manually set to PATH_MESH_TYPE to specify the type of the face)

I've seen no tick box or whatsoever on the editor so I assume I'll have to do it "manually" ?

Is there a way to ask the pathWorld to use only quads and regenerate it ?

Can the feature in world editor could be added for the pathmesh to choose quads or triangles as default pathmesh ?
10-01-2014 10:06 PM
Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #4
RE: Issues with Editor generated pathmesh
EE1.0 2D path is not the same as the later introduced 1.0 navmesh or navmesh in later version of the engine. pathWorld is 3d pathfinding. There is no choice between triangles and quads, it will always be triangles in the navmesh. I personally have never had this issue(connection issues) of all accessible triangles.
10-02-2014 01:37 PM
Find all posts by this user Quote this message in a reply
Pherael Offline
Silver Supporter

Post: #5
RE: Issues with Editor generated pathmesh
I have ones (but long time ago) similar issue as OP. It has happened when world was totally flat. Adding some object with physic and terrain transforms fix the problem. Not sure if it is related in any way, but maybe it will help.
10-02-2014 01:48 PM
Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #6
RE: Issues with Editor generated pathmesh
Might be that the edges of the terrain isn't actually getting connected when completely flat?
how about trying to use smooth brush through all areas then check the navmesh again

you can watch the navmesh inside the editor without game or pressing the play button by using Ctrl+Alt+P
10-02-2014 02:44 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #7
RE: Issues with Editor generated pathmesh
Hello,

Can you attach a project with your world included? (you can create a new project, then copy the world element to that, and attach it here).

Quote:resulting on error when moving around in the world.
Please describe this error, screen with path would help.
10-03-2014 03:43 AM
Find all posts by this user Quote this message in a reply
KraaxLeNain Offline
Member

Post: #8
RE: Issues with Editor generated pathmesh
Hi.

The error occur mostly on the corner of areas (all triangle starts from hat corner) when trying to reach an obstacle (for example a tree).

I'll give a project illustrating this ASAP, thx for investigating this.

I'll also try to reproduce and catch with a screen shot the resulting bug in displacement.

Nota : @ Zervox are you sure you can't use quads ? Because the structure of pathwold contains pathmeshes wich can be created as quads too (see code in one on my post, it's extracted from the header of pathworld available in the API of documentation... Is it not up to date ?).

Video of the bug displacement (here at junction of 4 zones) : http://videobam.com/OQYzl

Seems when trying to cross that sometimes the path is not right (force to pass at the junction or doing a not direct way whereas there is no obstacle).

Code used for determining the path :
Code:
direct_path=Game.World.path().find(this.pos(), pos, path_to_go, 2, PMF_WALK, true);
(This post was last modified: 10-04-2014 09:22 AM by KraaxLeNain.)
10-03-2014 02:24 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #9
RE: Issues with Editor generated pathmesh
Hello!

The white things that you see are actually physics and not path mesh (that one is much simpler).

I have problems viewing the video link you have provided - please use YouTube for future.

Sometimes Recast will include some unnecessary path points at the area transitions, this is a known issue for Recast, you could try to workaround it somehow, perhaps see if there are no obstacles along the way between the neighbor points, then remove the middle point.

You can always ask for help in the Recast project website:
https://github.com/memononen/recastnavigation
https://groups.google.com/forum/#!forum/...navigation

If the library will be updated I'll be happy to incorporate the update into the engine.
11-03-2014 06:32 AM
Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #10
RE: Issues with Editor generated pathmesh
From what I see from EE on the github, the one currently in EE is a 6 month difference, also seem to be a few updates between those two points.
11-04-2014 10:39 PM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #11
RE: Issues with Editor generated pathmesh
Could you tell me if you know if there were any updates specific to this issue?
11-04-2014 11:12 PM
Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #12
RE: Issues with Editor generated pathmesh
Not sure if they are directly related, but some of them mention precision and number of iterations for the mesh generations.
11-04-2014 11:28 PM
Find all posts by this user Quote this message in a reply
Post Reply