About Store Forum Documentation Contact
Donations:
309$/mo



Post Reply 
Error when running custom shader apps
Author Message
3DRaddict Offline
Member

Post: #1
Error when running custom shader apps
I now get the following error when running any of my applications which use custom shaders

[Image: Problem3_3_10_14.jpg]

The error also occurs when running the Tutorial Shader apps.
The apps compile ok.

All these apps ran perfectly before the update.
10-03-2014 06:08 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Zervox Offline
Silver Supporter

Post: #2
RE: Error when running custom shader apps
I think the shader headers needs to be adjusted(he changed alot so headers could be defining something with different size as to what they currently are), also be sure you have no variables called AO in your shader( I am MR obvious).
(This post was last modified: 10-03-2014 06:17 PM by Zervox.)
10-03-2014 06:17 PM
Find all posts by this user Quote this message in a reply
3DRaddict Offline
Member

Post: #3
RE: Error when running custom shader apps
I forgot to mention that I only get this error when the app has been compiled using DX10+, not if a DX9 compile was used.
10-03-2014 06:48 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Offline
Administrator

Post: #4
RE: Error when running custom shader apps
Hello,

You'll need to recompile your shaders because the headers were changed.
I've added this to the release notes:
"-IMPORTANT: Custom shaders need to be recompiled"

Also I've updated the engine's source so the message will be more informative:
Exit(S+"Shader Param \""+param_name+"\"\nfrom Shader File \""+shader_name+"\"\nAlready exists in Shader Constants Map but with different parameters.\nThis means that some of your shaders were compiled with different headers.\nPlease recompile your shaders.");

Yes it happens only on DX10+ because only DX10+ packs shader constants in Shader Buffers.
So it will properly inform you that buffer from one shader is different from another shader if detected.

Thank you
10-04-2014 12:24 AM
Find all posts by this user Quote this message in a reply
3DRaddict Offline
Member

Post: #5
RE: Error when running custom shader apps
Thank you.
I copied all the shader headers from the latest engine build into my custom shader folder and recompiled each shader.
All back to normal now.smile
10-04-2014 05:47 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply