About Store Forum Documentation Contact
Donations:
158$/mo



Post Reply 
[BUG REPORT]Waiting 1 World Area (RESOLVED)
Author Message
Jben Offline
Member

Post: #1
[BUG REPORT]Waiting 1 World Area (RESOLVED)
Hello,
I report bug in last version Esenhtel.

Building World no work. Look video:





I can't Publish my project..

Thanks
(This post was last modified: 07-21-2016 12:20 PM by Jben.)
07-18-2016 11:48 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #2
RE: [BUG REPORT]Waiting 1 World Area
Hi,

Thank you for reporting the problem,

I've tried to reproduce the issue on latest editor, but it works fine for me.

Could you provide a sample project that has this issue?
If you can't reproduce it in a smaller project, can your compress this entire project and for example provide me a dropbox link?
07-19-2016 11:24 AM
Find all posts by this user Quote this message in a reply
Jben Offline
Member

Post: #3
RE: [BUG REPORT]Waiting 1 World Area
thanks!

but i dont export .esenthel project..
07-19-2016 11:29 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Zervox Offline
Member

Post: #4
RE: [BUG REPORT]Waiting 1 World Area
Could you try to right click world and copy it, never know if that might just work.
07-19-2016 11:38 AM
Find all posts by this user Quote this message in a reply
Jben Offline
Member

Post: #5
RE: [BUG REPORT]Waiting 1 World Area
The world copie is empty..

Esenhtel i send PM for acces project..
07-19-2016 11:42 AM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #6
RE: [BUG REPORT]Waiting 1 World Area
The problem is that 3 of your objects in world:
UID(97440806, 1167593580, 810252687, 4217297253)
UID(4111360017, 1125214588, 938746767, 2093860998)
UID(3738476903, 1287191497, 2623109023, 1476963101)

Have invalid scale/rotation - NaN not a number, invalid floating point value.

You can find the objects in the "World Editor \ Object Tab \ Object List" and paste their UID(..)

Do you have any idea how did the scale/rotation values of these objects become NaN?
Perhaps did you use Editor Network Interface methods with invalid parameters?
07-20-2016 04:17 AM
Find all posts by this user Quote this message in a reply
Jben Offline
Member

Post: #7
RE: [BUG REPORT]Waiting 1 World Area
Thanks !

I find just one UID.. no results for two other UID (3 hours search on World).

how did you find these 3 Error?

We use the data server for 2 years, I do not know why these error...
07-20-2016 07:58 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #8
RE: [BUG REPORT]Waiting 1 World Area
Hi,

I think the objects are close to world center, around world area (2,2).

You can use Editor Network Interface to obtain precise location.

I suggest deleting them.

I think I've solved the 2 problems (of crash when dragging world to mini map, and waiting for 1 area rebuild).
I will now upload the fix.
07-21-2016 07:40 AM
Find all posts by this user Quote this message in a reply
Esenthel Online
Administrator

Post: #9
RE: [BUG REPORT]Waiting 1 World Area
The fix is now available.

After you delete the objects, please let me know if it works OK now.
07-21-2016 08:16 AM
Find all posts by this user Quote this message in a reply
Jben Offline
Member

Post: #10
RE: [BUG REPORT]Waiting 1 World Area
Thanks for all.. It's Work ok for me.

Long life to ESENTHEL !
07-21-2016 12:20 PM
Visit this user's website Find all posts by this user Quote this message in a reply
Post Reply